xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / gphoto2 / libgphoto2_2.4.4.bb
1 DESCRIPTION = "libgphoto2 allows you to access digital cameras"
2 SECTION = "libs"
3 LICENSE = "GPL"
4 DEPENDS = "libtool jpeg virtual/libusb0 libexif"
5
6 PR = "r0"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
9
10 inherit autotools pkgconfig lib_package
11
12 OE_LT_RPATH_ALLOW=":${libdir}:"
13 OE_LT_RPATH_ALLOW[export]="1"
14
15 EXTRA_OECONF = " --with-drivers=all ac_cv_lib_ltdl_lt_dlcaller_register=yes"
16
17 PACKAGES =+ "libgphotoport libgphoto2-camlibs"
18 FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
19 RDEPENDS_${PN} = "libgphoto2-camlibs"
20
21 FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*" 
22
23 FILES_${PN} += "${libdir}/udev/*"
24 FILES_${PN}-dbg += "${libdir}/*/*/.debug"
25
26 do_stage() {
27         autotools_stage_all
28 }
29
30