sg3-utils: add newer buildable version
[openembedded.git] / recipes / gpe-bootsplash / gpe-bootsplash_svn.bb
1 SECTION = "gpe"
2 PRIORITY = "optional"
3 LICENSE = "GPL"
4 DEPENDS = "gtk+ libsvg-cairo"
5 PR = "r1"
6 PV = "1.15+svn-${SRCDATE}"
7
8 inherit autotools
9
10 SRC_URI += "${GPE_SVN} \
11             file://splash-p.svg \
12             file://splash-l.svg \
13             file://init.patch;patch=1 \
14             file://svn-build.patch;patch=1"
15
16 S = "${WORKDIR}/${PN}"
17
18
19 do_install_append() {
20         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
21         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
22         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
23 }
24
25 FILES_${PN} += "${datadir}/gpe"
26
27 pkg_postinst() {
28         update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
29         update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
30 }
31 pkg_postrm() {
32         update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
33         update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
34 }
35
36 DEFAULT_PREFERENCE = "-1"