sg3-utils: add newer buildable version
[openembedded.git] / recipes / gpe-bootsplash / gpe-bootsplash_1.14.bb
1 inherit gpe
2
3 DEPENDS = "gtk+ libsvg-cairo"
4 SECTION = "gpe"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PR = "r7"
8
9 SRC_URI += "file://splash-p.svg file://splash-l.svg \
10             file://c7x0-rotation.patch;patch=1 \
11             file://cxx0-rotation.patch;patch=1 \
12             file://cairofix.patch;patch=1 \
13             file://no-strip-on-install.patch;patch=1"
14
15 SRC_URI_append_mnci = " file://mnci.patch;patch=1"
16
17 FILES_${PN} += "${datadir}/gpe"
18
19 do_install_append() {
20         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
21         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
22         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S03bootsplash
23 }
24