psplash: Changed to 1.72RC
[openembedded.git] / recipes / glib-2.0 / glib-2.0_2.42.0.bb
1 DESCRIPTION = "GLib is a general-purpose utility library, \
2 which provides many useful data types, macros, \
3 type conversions, string utilities, file utilities, a main \
4 loop abstraction, and so on. It works on many \
5 UNIX-like platforms, Windows, OS/2 and BeOS."
6 LICENSE = "LGPLv2+"
7 SECTION = "libs"
8 PRIORITY = "optional"
9 PR = "r2"
10 DEPENDS += "glib-2.0-native virtual/libiconv zlib"
11 DEPENDS += "libffi python-argparse-native zlib"
12 DEPENDS_virtclass-native += "pkgconfig-native gettext-native libffi-native zlib-native"
13 DEPENDS_virtclass-nativesdk += "nativesdk-libtool nativesdk-gettext nativesdk-libffi nativesdk-zlib ${BPN}-native"
14
15 SRC_URI = "\
16            http://ftp.gnome.org/pub/GNOME/sources/glib/2.42/glib-${PV}.tar.xz \
17            file://configure-libtool.patch;patch=1 \
18            file://fix-conflicting-rand.patch;patch=1 \
19            file://add-march-i486-into-CFLAGS-automatically.patch;patch=1 \
20            file://glib-2.0-configure-readlink.patch;patch=1 \
21            file://uclibc.patch;patch=1 \
22            file://0001-configure.ac-Do-not-use-readlink-when-cross-compilin.patch;patch=1 \
23            file://allow-run-media-sdX-drive-mount-if-username-root.patch;patch=1 \
24            file://properties_deprecation.patch;patch=1 \
25 "
26
27 SRC_URI[md5sum] = "71af99768063ac24033ac738e2832740"
28 SRC_URI[sha256sum] = "94fbc0a7d10633433ff383e540607de649c1b46baaa59dea446a50977a6c4472"
29
30 inherit autotools gettext gtk-doc pkgconfig
31
32 S = "${WORKDIR}/glib-${PV}"
33
34 EXTRA_OECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap --disable-man --enable-included-printf=no --disable-modular-tests --disable-selinux"
35
36 do_configure_prepend() {
37         sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
38 }
39
40 ARM_INSTRUCTION_SET = "arm"
41 USE_NLS = "yes"
42
43 do_install_append() {
44   if [ "${PN}" != "glib-2.0-native" ]; then
45     sed ${D}${bindir}/gtester-report -i -e 's,${STAGING_BINDIR_NATIVE},${bindir},g'
46   fi
47
48   # remove some unpackaged files
49   rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyc
50   rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyo
51   # and empty dirs
52   rm -rf ${D}${libdir}/gio
53
54   # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
55   # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
56   if [ -f ${D}${bindir}/glib-mkenums ]; then
57     sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
58   fi
59 }
60
61 EXTRA_OECONF_virtclass-native = "--disable-dtrace --disable-systemtap"
62
63 do_configure_prepend_virtclass-native() {
64     if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
65                 echo "${TARGET_SYS}-libtool already present"
66     else
67         cp ${STAGING_BINDIR}/${TARGET_SYS}-libtool ${S}
68     fi
69
70 }
71
72 #BBCLASSEXTEND = "native"
73 BBCLASSEXTEND = "native nativesdk"
74
75 PACKAGES =+ "gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 glib-2.0-utils ${PN}-bash-completion ${PN}-codegen"
76 LEAD_SONAME = "libglib-2.0.*"
77 FILES_${PN}-utils = "${bindir}/* ${datadir}/glib-2.0/gettext"
78 FILES_${PN} = "${libdir}/lib*so.* ${libdir}/gio/modules/*.so \
79                ${datadir}/glib-2.0/schemas \
80                ${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
81 FILES_${PN}-dev += "${libdir}/glib-2.0/include \
82                     ${libdir}/gio/modules/*.la"
83 FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb \
84                     ${libdir}/gio/modules/.debug"
85
86 FILES_gmodule-2.0 = "${libdir}/libgmodule-2.0.so.*"
87 FILES_gobject-2.0 = "${libdir}/libgobject-2.0.so.*"
88 FILES_gio-2.0 = "${libdir}/libgio-2.0.so.*"
89 FILES_gthread-2.0 = "${libdir}/libgthread-2.0.so.*"
90 FILES_${PN}-codegen = "${libdir}/gdbus-2.0/codegen/*.py"
91 FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d \
92                                ${datadir}/bash-completion"
93
94 # Let various glib components end up in glib package
95 # for compatibility (with binary packages from Maemo).
96 FILES_gthread-2.0_chinook-compat = ""
97 FILES_gmodule-2.0_chinook-compat = ""
98 FILES_gobject-2.0_chinook-compat = ""
99 FILES_gio-2.0_chinook-compat = ""