rename packages/ to recipes/ per earlier agreement
[openembedded.git] / recipes / freesmartphone / fso-gpsd_git.bb
1 DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
2 LICENSE = "GPL"
3 SECTION = "network"
4 DEPENDS = "dbus-glib"
5 PV = "0.8+gitr${SRCREV}"
6 PR = "r2"
7
8 SRC_URI = "\
9   ${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master \
10   file://fso-gpsd \
11 "
12 S = "${WORKDIR}/git"
13
14 inherit autotools update-rc.d
15
16 INITSCRIPT_NAME = "fso-gpsd"
17 INITSCRIPT_PARAMS = "defaults 35"
18
19 do_install_append() {
20     install -d ${D}${sysconfdir}/init.d/
21     install -m 0755 ${WORKDIR}/fso-gpsd ${D}${sysconfdir}/init.d/
22 }
23
24 FILES_${PN} += "${sysconfdir}"
25 RDEPENDS_${PN} = "frameworkd"
26 RPROVIDES_${PN} = "gpsd"
27 # Disabled as we always got gpsd but not fso-gpsd in the fso-image. Needs
28 # fixing.
29 #RCONFLICTS_${PN} = "gpsd"