sg3-utils: add newer buildable version
[openembedded.git] / recipes / freesmartphone / fso-abyss_git.bb
1 DESCRIPTION = "Abyss is a GSM 07.10 muxer userspace daemon"
2 HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/Abyss"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
4 SECTION = "console/network"
5 DEPENDS = "vala-native dbus dbus-glib libgsm0710mux"
6 LICENSE = "GPL"
7 SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
8 PV = "0.9.2+gitr${SRCREV}"
9 PR = "r0"
10
11 SRC_URI = "\
12   ${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master \
13   file://fso-abyss.conf \
14 "
15 S = "${WORKDIR}/git/tools/fso-abyss"
16
17 inherit autotools_stage
18
19 do_install_append() {
20         install -d ${D}${sysconfdir}
21         install -m 0644 ${WORKDIR}/fso-abyss.conf ${D}${sysconfdir}/
22 }
23
24 PACKAGES =+ "${PN}-config"
25
26 FILES_${PN} += "${sysconfdir} ${datadir}"
27
28 RRECOMMENDS_${PN} = "${PN}-config"
29
30 FILES_${PN}-config = "\
31   ${sysconfdir}/fso-abyss.conf \
32 "
33
34 CONFFILES_${PN}-config = "\
35   ${sysconfdir}/fso-abyss.conf \
36 "
37
38 PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"