psplash: Changed to 1.72RC
[openembedded.git] / recipes / duma / duma_2.5.7.bb
1 DESCRIPTION = "A Red-Zone memory allocator to detect unintended memory access"
2 HOMEPAGE = "http://duma.sourceforge.net"
3 LICENSE = "GPL LGPL"
4 SECTION = "devel"
5 DEPENDS = "qemu-native"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/duma/duma_2_5_7.tar.gz"
8
9 S = "${WORKDIR}/duma_2_5_7"
10
11 EXTRA_OECONF = "-e"
12
13 do_configure () {
14         oe_runmake createconf
15         qemu-${TARGET_ARCH} -L ${STAGING_DIR_HOST} ./createconf
16 }
17
18 do_compile () {
19         oe_runmake libduma.a libduma.so.0.0
20 }
21
22 do_install () {
23         install -d ${D}${base_bindir}
24         install -d ${D}${base_libdir}
25         install -d ${D}${mandir}/man3
26         oe_runmake install prefix="${D}" MAN_INSTALL_DIR="${D}${mandir}/man3"
27 }