omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / cpusage / cpusage_0.2.bb
1 DESCRIPTION = "This tool read out the tics counter of the operating system and \
2 calculates the Percentages spend in each CPU_STATE."
3 SECTION = "base"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6
7 SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz"
8
9 S = "${WORKDIR}/cpusage-${PV}"
10
11 FILES_${PN} = "/sbin/cpusage"
12
13 CFLAGS_append =" -D_BSD_SOURCE=1"
14 CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
15
16
17 do_compile() {
18         ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
19 }
20
21 do_install() {
22         install -d ${D}${base_sbindir}
23         install -m 0755 cpusage ${D}${base_sbindir}/cpusage
24 }