omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / classpathx / gnujaf_1.1.1.bb
1 DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
2 LICENSE = "GPL + library exception"
3 AUTHOR = "GNU ClasspathX"
4
5 SRC_URI = "\
6   http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
7   file://datadir_java.patch;patch=1 \
8   "
9
10 # java-library must be last (it defines do_stage)
11 inherit autotools java-library
12
13 S = "${WORKDIR}/activation-${PV}"
14
15 DEPENDS = "fastjar-native"
16
17 export JAVAC = "javac"
18
19 # Fake javadoc
20 export JAVADOC = "true"
21
22 JARFILENAME = "activation-${PV}.jar"
23 ALTJARFILENAMES = "activation.jar gnujaf.jar"
24
25 do_compile() {
26   mkdir -p build
27
28   javac -sourcepath source -d build `find source -name "*.java"`
29
30   fastjar -C build -c -f ${JARFILENAME} .
31 }
32
33 do_install() {
34   java_install
35 }