Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / bluez / bluez-utils_3.33.bb
1 require bluez-utils3.inc
2
3 PR = "r3"
4
5 # see bluez-utils3.inc for the explanation of these option
6 EXTRA_OECONF = " \
7                  --enable-bccmd \
8                  --enable-hid2hci \
9                  --enable-hidd \
10                  --enable-pand \
11                  --enable-dund \
12                  --disable-alsa \ 
13                  --disable-cups \
14                  --enable-glib \
15                  --disable-sdpd \
16                  --enable-network \
17                  --enable-serial \
18                  --enable-input \
19                  --enable-audio \
20                  --enable-echo \
21                  --enable-configfile \
22                  --enable-initscripts \
23                 --enable-test \
24                 --enable-hidd \
25                 --enable-obex \
26                 --enable-pand \
27                 --enable-dund \
28                 --enable-avctrl \
29                 --enable-hid2hci \
30                 --enable-dfutool \
31                 " 
32
33 CONFFILES_${PN} = " \
34                    ${sysconfdir}/bluetooth/hcid.conf \
35                    ${sysconfdir}/default/bluetooth \
36                   "
37
38 CONFFILES_${PN}-compat = " \
39                           ${sysconfdir}/bluetooth/rfcomm.conf \
40                          "
41
42 PACKAGES =+ "bluez-audio"
43
44 FILES_${PN} = " \
45                ${base_sbindir}/hcid \
46                ${libdir}/bluetooth/plugins/*.so \
47                ${sysconfdir}/init.d/bluetooth \
48                ${sysconfdir}/bluetooth/hcid.conf \
49                ${sysconfdir}/default \
50                ${sysconfdir}/dbus-1 \
51                ${base_sbindir}/hciattach \
52               "
53
54 FILES_bluez-audio = " \
55                      ${libdir}/bluetooth/plugins/libaudio.so \
56                      ${libdir}/gstreamer-0.10/*.so \
57                     "
58
59 FILES_${PN}-dbg += " \
60                     ${libdir}/bluetooth/plugins/.debug \
61                     ${libdir}/gstreamer-0.10/.debug \
62                    "
63
64 FILES_${PN}-dev += " \
65                     ${libdir}/bluetooth/plugins/*.la \
66                     ${libdir}/gstreamer-0.10/*.la \
67                    "