xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / binutils / binutils_cvs.bb
1 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-cvs"
2 PV = "2.20+cvs${SRCDATE}"
3 INC_PR = "r5"
4 PR = "${INC_PR}.1"
5
6 require binutils.inc
7
8 S = "${WORKDIR}/src"
9 EXTRA_OEMAKE = "configure-build-libiberty"
10 SRC_URI = "cvs://anoncvs:anoncvs@sources.redhat.com/cvs/src;module=binutils;method=pserver;localdir=src \
11      file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1;maxdate=20090801 \
12      file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
13      file://110-arm-eabi-conf.patch;patch=1 \
14      file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
15      file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
16      file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
17      file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
18      "
19
20 do_compile () {
21         oe_runmake all-ld all-binutils all-gas
22 }
23 do_install () {
24         oe_runmake 'DESTDIR=${D}' install-ld install-binutils install-gas
25
26         # We don't really need these, so we'll remove them...
27         rm -rf ${D}${libdir}/ldscripts
28
29         # Fix the /usr/${TARGET_SYS}/bin/* links
30         for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
31                 rm -f $l
32                 ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
33                         | tr -s / \
34                         | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
35         done
36
37         # Install the libiberty header
38         install -d ${D}${includedir}
39         install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
40         install -m 644 ${S}/include/libiberty.h ${D}${includedir}
41
42         cd ${D}${bindir}
43
44         # Symlinks for ease of running these on the native target
45         for p in ${TARGET_SYS}-* ; do
46                 ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
47         done
48
49         rm ${D}${bindir}/ar ${D}${bindir}/strings
50 }
51
52 do_stage () {
53         oe_libinstall -so -a -C opcodes libopcodes ${STAGING_LIBDIR}/
54         oe_libinstall -a -C libiberty libiberty ${STAGING_LIBDIR}/
55         oe_libinstall -so -a -C bfd libbfd ${STAGING_LIBDIR}/
56         install -m 0644 ${S}/include/dis-asm.h ${STAGING_INCDIR}/
57         install -m 0644 ${S}/include/symcat.h ${STAGING_INCDIR}/
58         install -m 0644 ${S}/include/libiberty.h ${STAGING_INCDIR}/
59         install -m 0644 ${S}/include/ansidecl.h ${STAGING_INCDIR}/
60         install -m 0644 ${S}/include/bfdlink.h ${STAGING_INCDIR}/
61         install -m 0644 bfd/bfd.h ${STAGING_INCDIR}/
62 }