Introduce STAGING_BINDIR_CROSS and STAGING_BINDIR_NATIVE as discussed on the mailing...
[openembedded.git] / packages / subversion / subversion_1.3.1.bb
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util-0.9.12 neon"
4 LICENSE = "Apache/BSD"
5 HOMEPAGE = "http://subversion.tigris.org"
6 PR = "r1"
7
8 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
9            file://disable-revision-install.patch;patch=1 \
10            file://apr-regex.patch;patch=1"
11
12 EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${BUILD_SYS} \
13                 --without-berkeley-db --without-apxs --without-apache \
14                 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
15                 --with-apr-util=${STAGING_BINDIR_CROSS}"
16
17 inherit autotools
18
19 do_configure() {
20         oe_runconf
21 }
22
23 do_stage() {
24         autotools_stage_all
25 }