Introduce STAGING_BINDIR_CROSS and STAGING_BINDIR_NATIVE as discussed on the mailing...
[openembedded.git] / packages / regina-rexx / regina-rexx_3.3.bb
1 DESCRIPTION = "A cross-platform REXX interpreter"
2 SECTION = "devel/rexx"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://regina-rexx.sf.net"
5 DEPENDS = "regina-rexx-native"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/regina-rexx/regina33.zip \
8            file://use-proper-host-tools.patch;patch=1"
9 S = "${WORKDIR}"
10
11 inherit autotools
12
13 PARALLEL_MAKE = ""
14
15 # need to use configure script built by ancient autotools
16 do_configure() {
17         gnu-configize
18         oe_runconf
19 }
20
21 do_compile() {
22         oe_runmake STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
23 }
24
25 do_install() {
26         oe_runmake install bindir="${D}${bindir}" libdir="${D}${libdir}" includedir="${D}${includedir}" \
27                            sharedir="${D}${datadir}" mandir="${D}${mandir}" sysconfdir="${D}${sysconfdir}" \
28                            STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
29 }
30
31 FILES_${PN} += "${datadir}"
32