071a53e0cde7e66e0d225254f8f219cfe4b2b13f
[openembedded.git] / packages / libnet / libnet_1.0.2a.bb
1 DESCRIPTION = "Libnet is a collection of routines to help with \
2 the construction and handling of network packets. It provides a \
3 portable framework for low-level network packet shaping, \
4 handling, and injection."
5 SECTION = "libs/network"
6 LICENSE = "GPL"
7 PR = "r1"
8
9 # There are major API changes beween libnet v1.0 and libnet v1.1
10 PROVIDES = "libnet-1.0"
11
12 SRC_URI = "http://www.packetfactory.net/libnet/dist/deprecated/libnet-${PV}.tar.gz \
13            file://configure.patch;patch=1 \
14            file://configure.uclibc.patch;patch=1 \
15            "
16 S = "${WORKDIR}/Libnet-${PV}"
17
18 inherit autotools
19
20 CPPFLAGS_prepend = "-I${S}/libnet/include -DHAVE_PF_PACKET "
21 EXTRA_OEMAKE = "'LIB_PREFIX=${libdir}/' 'MAN_PREFIX=${mandir}/' \
22                 'BIN_PREFIX=${bindir}/' 'INC_PREFIX=${includedir}/'"
23
24 #FIXME: (fixing this would remove the need for configure.uclibc.patch above)
25 do_configure() {
26         oe_runconf
27 }
28
29 do_stage() {
30         install -m 0755 libnet-config ${STAGING_BINDIR}/
31         install -m 0644 include/libnet.h ${STAGING_INCDIR}/
32         install -d ${STAGING_INCDIR}/libnet
33         install -m 0644 include/libnet/libnet-headers.h ${STAGING_INCDIR}/libnet/
34         install -m 0644 include/libnet/libnet-functions.h ${STAGING_INCDIR}/libnet/
35         install -m 0644 include/libnet/libnet-structures.h ${STAGING_INCDIR}/libnet/
36         install -m 0644 include/libnet/libnet-macros.h ${STAGING_INCDIR}/libnet/
37         install -m 0644 include/libnet/libnet-asn1.h ${STAGING_INCDIR}/libnet/
38         install -m 0644 include/libnet/libnet-ospf.h ${STAGING_INCDIR}/libnet/
39         oe_libinstall -a -C lib libnet ${STAGING_LIBDIR}
40 }