gstreamer 0.10.x: unify bb files and make hrw happy ;-)
[openembedded.git] / packages / dbus / dbus_0.91.bb
1 DEFAULT_PREFERENCE="-1"
2
3 SECTION = "base"
4 PR = "r1"
5 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
6 DESCRIPTION = "message bus system for applications to talk to one another"
7 LICENSE = "GPL"
8 DEPENDS = "expat glib-2.0 virtual/libintl"
9
10 SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
11            file://cross.patch;patch=1 \
12            file://tmpdir.patch;patch=1 \
13            file://dbus-1.init \
14            file://fix-segfault.patch;patch=1"
15
16 inherit autotools pkgconfig update-rc.d gettext
17
18 INITSCRIPT_NAME = "dbus-1"
19 INITSCRIPT_PARAMS = "defaults"
20
21 CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
22
23 FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
24 FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
25
26 pkg_postinst_dbus() {
27 #!/bin/sh
28
29 # can't do adduser stuff offline
30 if [ "x$D" != "x" ]; then
31   exit 1
32 fi
33
34 MESSAGEUSER=messagebus
35 MESSAGEHOME=/var/run/dbus
36
37 mkdir -p $MESSAGEHOME || true
38 chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
39 chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
40 }
41
42 EXTRA_OECONF = "--disable-qt  --disable-qt3 --disable-gtk --disable-tests \
43                 --disable-checks --disable-xml-docs --disable-doxygen-docs \
44                 --with-xml=expat --without-x"
45
46 do_stage () {
47         oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
48
49         autotools_stage_includes
50
51         mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
52         install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
53 }
54
55 do_install_append () {
56         install -d ${D}${sysconfdir}/init.d
57         install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
58 }
59
60 python populate_packages_prepend () {
61         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
62                 bb.data.setVar('PKG_dbus', 'dbus-1', d)
63 }