ad89228fff9c2d462334f0a0af2aa69cb607fc44
[openembedded.git] / packages / apr / apr-util_1.1.2.bb
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
5
6 PR = "r0"
7
8 # apache mirrors?
9 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz"
10
11 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
12
13 inherit autotools lib_package binconfig
14
15 do_configure() {
16   oe_runconf
17 }
18
19 do_stage() {
20   oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
21 }