ncurses: add xterm terminfo file back
[openembedded.git] / classes / update-alternatives.bbclass
1 # defaults
2 ALTERNATIVE_PRIORITY = "10"
3 ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
4
5 update_alternatives_postinst() {
6 update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
7 }
8
9 update_alternatives_postrm() {
10 update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
11 }
12
13 def update_alternatives_after_parse(d):
14     if bb.data.getVar('ALTERNATIVE_NAME', d) == None:
15         raise bb.build.FuncFailed, "%s inherits update-alternatives but doesn't set ALTERNATIVE_NAME" % bb.data.getVar('FILE', d)
16     if bb.data.getVar('ALTERNATIVE_PATH', d) == None:
17         raise bb.build.FuncFailed, "%s inherits update-alternatives but doesn't set ALTERNATIVE_PATH" % bb.data.getVar('FILE', d)
18
19 python __anonymous() {
20     update_alternatives_after_parse(d)
21 }
22
23 python populate_packages_prepend () {
24         pkg = bb.data.getVar('PN', d, 1)
25         bb.note('adding update-alternatives calls to postinst/postrm for %s' % pkg)
26         postinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, 1) or bb.data.getVar('pkg_postinst', d, 1)
27         if not postinst:
28                 postinst = '#!/bin/sh\n'
29         postinst += bb.data.getVar('update_alternatives_postinst', d, 1)
30         bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
31         postrm = bb.data.getVar('pkg_postrm_%s' % pkg, d, 1) or bb.data.getVar('pkg_postrm', d, 1)
32         if not postrm:
33                 postrm = '#!/bin/sh\n'
34         postrm += bb.data.getVar('update_alternatives_postrm', d, 1)
35         bb.data.setVar('pkg_postrm_%s' % pkg, postrm, d)
36 }