xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / srec.bbclass
1 #
2 # Creates .srec files from images.
3 #
4 # Useful for loading with Yamon.
5
6 # Define SREC_VMAADDR in your machine.conf.
7
8 SREC_CMD = "${TARGET_PREFIX}objcopy -O srec -I binary --adjust-vma ${SREC_VMAADDR} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.${type} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.${type}.srec"
9
10 # Do not build srec files for these types of images:
11 SREC_SKIP = "tar"
12
13 do_srec[nostamp] = "1"
14
15 do_srec () {
16     if [ ${SREC_VMAADDR} = "" ] ; then
17        oefatal Cannot do_srec without SREC_VMAADDR defined.
18     fi
19     for type in ${IMAGE_FSTYPES}; do
20         for skiptype in ${SREC_SKIP}; do
21             if [ $type = $skiptype ] ; then continue 2 ; fi
22         done
23         ${SREC_CMD}
24     done
25     return 0
26 }
27
28 addtask srec after do_rootfs before do_build