merge of '821236cd07549d1b91216012a2ef789aaad4c7a0'
[openembedded.git] / classes / scons.bbclass
1 DEPENDS += "python-scons-native"
2
3 scons_do_compile() {
4         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${prefix} prefix=${prefix} || \
5         oefatal "scons build execution failed."
6 }
7
8 scons_do_install() {
9         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install || \
10         oefatal "scons install execution failed."
11 }
12
13 EXPORT_FUNCTIONS do_compile do_install