firefox: Perform a number of cleanups and fix consistency issues.
[openembedded.git] / classes / scons.bbclass
1 DEPENDS += "python-scons-native"
2
3 scons_do_compile() {
4         ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} PREFIX=${prefix} prefix=${prefix} || \
5         oefatal "scons build execution failed."
6 }
7
8 scons_do_install() {
9         install -d ${D}${prefix}
10         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install || \
11         oefatal "scons install execution failed."
12 }
13
14 scons_do_stage() {
15         install -d ${D}${prefix}
16         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${STAGING_DIR_HOST}/${prefix} prefix=${STAGING_DIR_HOST}/${prefix} install || \
17         oefatal "scons stage execution failed."
18 }
19
20 EXPORT_FUNCTIONS do_compile do_install do_stage