sg3-utils: add newer buildable version
[openembedded.git] / classes / python-dir.bbclass
1 def python_dir(d):
2         import os, bb
3         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
4         for majmin in "2.7 2.6 2.5 2.4 2.3".split():
5                 if os.path.exists( "%s/python%s" % ( staging_incdir, majmin ) ): return "python%s" % majmin
6         if not "python-native" in bb.data.getVar( "DEPENDS", d, 1 ).split():
7                 raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
8         return "INVALID"
9
10 PYTHON_DIR = "${@python_dir(d)}"
11 PYTHON_SITEPACKAGES_DIR = "${libdir}/${PYTHON_DIR}/site-packages"