sg3-utils: add newer buildable version
[openembedded.git] / classes / pkgconfig.bbclass
1 DEPENDS_prepend = "pkgconfig-native "
2
3 do_install_prepend () {
4
5 for i in `find ${S}/ -name "*.pc" -type f` ; do \
6             sed -i -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' $i
7         done
8 }
9
10 SYSROOT_PREPROCESS_FUNCS += "pkgconfig_sysroot_preprocess"
11
12 pkgconfig_sysroot_preprocess () {
13         install -d ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}
14         for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
15                 pcname=`basename $pc`
16                 cat $pc > ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}/$pcname
17         done
18 }