xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / openmoko2.bbclass
1 inherit autotools pkgconfig
2
3 HOMEPAGE = "http://www.openmoko.org"
4 OPENMOKO_RELEASE ?= "OM-2007.2"
5 OPENMOKO_MIRROR ?= "svn://svn.openmoko.org/trunk"
6
7 def openmoko_two_get_license(d):
8     openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
9     return "LGPL GPL".split()[section != "libs"]
10
11 def openmoko_two_get_subdir(d):
12     openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
13     if section == 'base': return ""
14     elif section == 'libs': return "libraries"
15     elif section in 'apps tools pim'.split(): return "applications"
16     elif section == "panel-plugin": return "panel-plugins"
17     elif section == "inputmethods": return "inputmethods"
18     elif section == "daemons": return "daemons"
19     elif section == "misc": return "misc"
20     else: return section
21
22 LICENSE = "${@openmoko_two_get_license(d)}"
23 SUBDIR = "${@openmoko_two_get_subdir(d)}"
24
25 SRC_URI := "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/${SUBDIR};module=${PN};proto=http"
26 S = "${WORKDIR}/${PN}"
27
28 FILES_${PN} += "${datadir}/icons"
29
30 SVNREV = "r${SRCREV}"
31 #SVNREV = "${SRCDATE}"