Merge branch 'org.openembedded.dev' of ssh+git://git@git.openembedded.net/openembedde...
[openembedded.git] / classes / oebuildstamp.bbclass
1 #
2 # Because base.oeclasses set the variable
3 #
4 #       do_fetch[nostamp] = "1"
5 #       do_build[nostamp] = "1"
6 #
7 # for every build we're doing oemake calls all of the phases to check if
8 # something new is to download. This class unset's this nostamp flag. This
9 # makes a package "finished", once it's completely build.
10 #
11 # This means that the subsequent builds are faster, but when you change the
12 # behaviour of the package, e.g. by adding INHERIT="package_ipk", you won't
13 # get the ipk file except you delete the build stamp manually or all of them
14 # with oebuild clean <oe-file>.
15
16 do_build[nostamp] = ""