java.bbclass: Fixed oe_makeclasspath classpath generation.
[openembedded.git] / classes / java.bbclass
1 # Defines the commonly used target directories and provides a convenience
2 # function to install jar files.
3 #
4 # All the default directory locations herein resemble locations chosen in
5 # the Debian distribution.
6
7 # Jar location on target
8 datadir_java ?= ${datadir}/java
9
10 # JNI library location on target
11 libdir_jni ?= ${libdir}/jni
12
13 # JVM bundle location on target
14 libdir_jvm ?= ${libdir}/jvm
15
16 STAGING_DATADIR_JAVA ?= ${STAGING_DATADIR}/java
17 STAGING_LIBDIR_JNI ?= ${STAGING_LIBDIR}/jni
18 STAGING_LIBDIR_JVM ?= ${STAGING_LIBDIR}/jvm
19
20 oe_jarinstall() {
21   # Purpose: Install a jar file and create all the given symlinks to it.
22   # Example:
23   # oe_jarinstall foo-1.3.jar foo.jar
24   # Installs foo-1.3.jar and creates symlink foo.jar.
25   #
26   # oe_jarinstall -s foo-1.3.jar foo.jar
27   # Installs foo-1.3.jar to staging and creates symlink foo.jar.
28   #
29   # oe_jarinstall -r foo-1.3.jar foo_1_3.jar foo.jar
30   # Installs foo_1_3.jar as foo-1.3.jar and creates a symlink to this.
31   #
32   dir=${D}${datadir_java}
33   destname=""
34   while [ "$#" -gt 0 ]; do
35     case "$1" in
36     -s)
37       dir=${STAGING_DATADIR_JAVA}
38       ;;
39     -r)
40       shift
41       destname=$1
42       ;;
43     -*)
44       oefatal "oe_jarinstall: unknown option: $1"
45       ;;
46     *)
47       break;
48       ;;
49     esac
50     shift
51   done
52
53   jarname=$1
54   destname=${destname:-`basename $jarname`}
55   shift
56
57   install -d $dir
58   install -m 0644 $jarname $dir/$destname
59
60   # Creates symlinks out of the remaining arguments.
61   while [ "$#" -gt 0 ]; do
62     if [ -e $dir/$1 ]; then
63       oewarn "file was in the way. removing:" $dir/$1
64       rm $dir/$1
65     fi
66     ln -s $destname $dir/$1
67     shift
68   done
69 }
70
71 oe_makeclasspath() {
72   # Purpose: Generate a classpath variable from the given Jar file names
73   # where the ".jar" has been omitted.
74   #
75   # oe_makeclasspath foo baz bar
76   # Prints ${datadir_java}/foo.jar:${datadir_java}/baz.jar:${datadir_java}/bar.jar
77   #
78   # oe_makeclasspath -s foo baz bar
79   # Prints ${STAGING_DATADIR_JAVA}/foo.jar:${STAGING_DATADIR_JAVA}/baz.jar:${STAGING_DATADIR_JAVA}/bar.jar
80   #
81   # Provide the -s at the beginning otherwise strange things happen.
82   #
83   dir=${datadir_java}
84         classpath=
85         delimiter=
86
87   while [ "$#" -gt 0 ]; do
88     case "$1" in
89     -s)
90       dir=${STAGING_DATADIR_JAVA}
91       ;;
92     -*)
93       oefatal "oe_makeclasspath: unknown option: $1"
94       ;;
95     *)
96       file=$dir/$1.jar
97
98                         if [ ! -f $file ]; then
99                                 oefatal "oe_makeclasspath: Jar file for '$1' not found at $file"
100                         fi
101
102       classpath=$classpath$delimiter$file
103       delimiter=":"
104       ;;
105     esac
106     shift
107   done
108
109         echo $classpath
110 }
111
112 # Creates a simple wrapper script for your Java program.
113 # The script is written to ${PN} by default. 
114 #
115 # Parameters are as follows:
116 # [options] <output file> <main class> [jar files ...]
117 #
118 # Options are
119 # -o <name> where name is the output file name
120 #
121 # It can only take jar files from ${datadir_java}!
122 oe_java_simple_wrapper() {
123   delimiter=
124   mainclass=
125   classpath=
126   output=${PN}
127
128   while [ "$#" -gt 0 ]; do
129     case "$1" in
130     -o)
131       shift
132       output=$1
133       ;;
134     -*)
135       oefatal "oe_java_simple_wrapper: unknown option: $1"
136       ;;
137     *)
138       if [ $mainclass ]
139       then
140         classpath=$classpath$delimiter${datadir_java}/$1
141         delimiter=":"
142       else
143         mainclass=$1
144       fi
145       ;;
146     esac
147     shift
148   done
149
150   oenote "Creating simple Java wrapper script"
151   oenote "Output File: $output"
152   oenote "Main Class: $mainclass"
153   oenote "Classpath: $classpath"
154
155   echo "#!/bin/sh" > $output
156   echo "# This file is autogenerated by the oe_java_simple_wrapper function of OpenEmbedded" >> $output
157   echo >> $output
158   echo "# You can provide additional VM arguments by setting the VMARGS environment variable." >> $output
159   echo "CLASSPATH_ARG=\"-cp $classpath\"" >> $output
160   echo >> $output
161   echo "MAIN_CLASS=$mainclass" >> $output
162   echo >> $output
163   echo "# Allows overriding the VM by setting the JAVA environment variable." >> $output
164   echo "if [ x\${JAVA} = x ]" >> $output
165   echo "then" >> $output
166   echo "  JAVA=java" >> $output
167   echo "fi" >> $output
168   echo >> $output
169   echo "exec \${JAVA} \${VMARGS} \${CLASSPATH_ARG} \${MAIN_CLASS} \${@}" >> $output
170 }