xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / gtk-icon-cache.bbclass
1 FILES_${PN} += "${datadir}/icons/hicolor"
2 RDEPENDS += "hicolor-icon-theme"
3
4 # This could run on the host as icon cache files are architecture independent,
5 # but there is no gtk-update-icon-cache built natively.
6 gtk_icon_cache_postinst() {
7 if [ "x$D" != "x" ]; then
8         exit 1
9 fi
10
11 # Update the pixbuf loaders in case they haven't been registered yet
12 gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
13
14 for icondir in /usr/share/icons/* ; do
15     if [ -d $icondir ] ; then
16         gtk-update-icon-cache -qt  $icondir
17     fi
18 done
19 }
20
21 gtk_icon_cache_postrm() {
22 for icondir in /usr/share/icons/* ; do
23     if [ -d $icondir ] ; then
24         gtk-update-icon-cache -qt  $icondir
25     fi
26 done
27 }
28
29 python populate_packages_append () {
30         packages = bb.data.getVar('PACKAGES', d, 1).split()
31         pkgdest =  bb.data.getVar('PKGDEST', d, 1)
32         
33         for pkg in packages:
34                 icon_dir = '%s/%s/%s/icons' % (pkgdest, pkg, bb.data.getVar('datadir', d, 1))
35                 if not os.path.exists(icon_dir):
36                         continue
37                 
38                 bb.note("adding gtk-icon-cache postinst and postrm scripts to %s" % pkg)
39                 
40                 postinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, 1) or bb.data.getVar('pkg_postinst', d, 1)
41                 if not postinst:
42                         postinst = '#!/bin/sh\n'
43                 postinst += bb.data.getVar('gtk_icon_cache_postinst', d, 1)
44                 bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
45
46                 postrm = bb.data.getVar('pkg_postrm_%s' % pkg, d, 1) or bb.data.getVar('pkg_postrm', d, 1)
47                 if not postrm:
48                         postrm = '#!/bin/sh\n'
49                 postrm += bb.data.getVar('gtk_icon_cache_postrm', d, 1)
50                 bb.data.setVar('pkg_postrm_%s' % pkg, postrm, d)
51 }
52