Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[openembedded.git] / classes / efl.bbclass
1 SECTION = "e/libs"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT BSD"
4 SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
5 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
6 S = "${WORKDIR}/${SRCNAME}"
7 DEPENDS += "pkgconfig-native"
8
9 # revision 0d93ec84b30bc1bee2caaee72d667f87bc468a70 made SRCDATE and hence PV go backwards, so we need to up PE to unbreak builds and feeds :(
10 PE = "2"
11
12 ARM_INSTRUCTION_SET = "arm"
13
14 AUTOTOOLS_STAGE_PKGCONFIG = "1"
15 # do NOT inherit pkgconfig here, see note in autotools_stage_all
16 inherit autotools
17
18 do_configure_prepend() {
19         touch config.rpath
20 }
21
22 do_stage() {
23         autotools_stage_all
24 }
25
26 PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-tests"
27
28 FILES_${PN} = "${libdir}/*.so.*"
29
30 FILES_${PN}-themes = "${datadir}/${PN}/themes \
31                       ${datadir}/${PN}/data \
32                       ${datadir}/${PN}/fonts \
33                       ${datadir}/${PN}/pointers \
34                       ${datadir}/${PN}/images \
35                       ${datadir}/${PN}/users \
36                       ${datadir}/${PN}/images \
37                       ${datadir}/${PN}/styles"
38
39 FILES_${PN}-dev   += "${bindir}/${PN}-config \
40                       ${libdir}/pkgconfig/* \
41                       ${libdir}/lib*.la \
42                       ${libdir}/lib*.a \
43                       ${libdir}/*.so \
44                       ${libdir}/${PN}/*.a \
45                       ${libdir}/${PN}/*.la \
46                       ${libdir}/${PN}/*/*.a \
47                       ${libdir}/${PN}/*/*.la"
48
49 FILES_${PN}-dbg +=   "${libdir}/${PN}/.debug \
50                       ${libdir}/${PN}/*/.debug"
51
52 FILES_${PN}-tests  = "${bindir}/${PN} \
53                       ${bindir}/*_* \
54                       ${datadir}"
55