Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org...
[openembedded.git] / classes / efl.bbclass
1 SECTION = "e/libs"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT BSD"
4 SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
5 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
6 S = "${WORKDIR}/${SRCNAME}"
7 DEPENDS += "pkgconfig-native"
8
9 # revision 0d93ec84b30bc1bee2caaee72d667f87bc468a70 made SRCDATE and hence PV go backwards, so we need to up PE to unbreak builds and feeds :(
10 PE = "2"
11
12 ARM_INSTRUCTION_SET = "arm"
13
14 AUTOTOOLS_STAGE_PKGCONFIG = "1"
15 # do NOT inherit pkgconfig here, see note in autotools_stage_all
16 inherit autotools
17
18 do_configure_prepend() {
19         touch config.rpath
20 }
21
22 do_stage() {
23         autotools_stage_all
24 }
25
26 # This construction is stupid, someone with more E knowledge should change it to =+ or something
27 PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests"
28
29 FILES_${PN} = "${libdir}/*.so.*"
30
31 FILES_${PN}-themes = "${datadir}/${PN}/themes \
32                       ${datadir}/${PN}/data \
33                       ${datadir}/${PN}/fonts \
34                       ${datadir}/${PN}/pointers \
35                       ${datadir}/${PN}/images \
36                       ${datadir}/${PN}/users \
37                       ${datadir}/${PN}/images \
38                       ${datadir}/${PN}/styles"
39
40 FILES_${PN}-dev   += "${bindir}/${PN}-config \
41                       ${libdir}/pkgconfig/* \
42                       ${libdir}/lib*.la \
43                       ${libdir}/lib*.a \
44                       ${libdir}/*.so \
45                       ${libdir}/${PN}/*.a \
46                       ${libdir}/${PN}/*.la \
47                       ${libdir}/${PN}/*/*.a \
48                       ${libdir}/${PN}/*/*.la"
49
50 FILES_${PN}-dbg +=   "${libdir}/${PN}/.debug \
51                       ${libdir}/${PN}/*/.debug"
52
53 FILES_${PN}-tests  = "${bindir}/${PN} \
54                       ${bindir}/*_* \
55                       ${datadir}"
56