Merge branch 'mickey/python26' into org.openembedded.dev
[openembedded.git] / classes / efl.bbclass
1 SECTION = "e/libs"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT BSD"
4 SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
5 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
6 S = "${WORKDIR}/${SRCNAME}"
7 DEPENDS += "pkgconfig-native"
8
9 # revision 0d93ec84b30bc1bee2caaee72d667f87bc468a70 made SRCDATE and hence PV go backwards, so we need to up PE to unbreak builds and feeds :(
10 PE = "2"
11
12 ARM_INSTRUCTION_SET = "arm"
13
14 AUTOTOOLS_STAGE_PKGCONFIG = "1"
15 # do NOT inherit pkgconfig here, see note in autotools_stage_all
16 inherit autotools
17
18 do_stage() {
19         autotools_stage_all
20 }
21
22 PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-tests"
23
24 FILES_${PN} = "${libdir}/*.so.*"
25
26 FILES_${PN}-themes = "${datadir}/${PN}/themes \
27                       ${datadir}/${PN}/data \
28                       ${datadir}/${PN}/fonts \
29                       ${datadir}/${PN}/pointers \
30                       ${datadir}/${PN}/images \
31                       ${datadir}/${PN}/users \
32                       ${datadir}/${PN}/images \
33                       ${datadir}/${PN}/styles"
34
35 FILES_${PN}-dev   += "${bindir}/${PN}-config \
36                       ${libdir}/pkgconfig/* \
37                       ${libdir}/lib*.la \
38                       ${libdir}/lib*.a \
39                       ${libdir}/*.so \
40                       ${libdir}/${PN}/*.a \
41                       ${libdir}/${PN}/*.la \
42                       ${libdir}/${PN}/*/*.a \
43                       ${libdir}/${PN}/*/*.la"
44
45 FILES_${PN}-dbg +=   "${libdir}/${PN}/.debug \
46                       ${libdir}/${PN}/*/.debug"
47
48 FILES_${PN}-tests  = "${bindir}/${PN} \
49                       ${bindir}/*_* \
50                       ${datadir}"
51