Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / classes / efl.bbclass
1 SECTION = "e/libs"
2 HOMEPAGE = "http://www.enlightenment.org"
3 LICENSE = "MIT BSD"
4 SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
5 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
6 S = "${WORKDIR}/${SRCNAME}"
7 DEPENDS += "pkgconfig-native"
8
9 # revision 0d93ec84b30bc1bee2caaee72d667f87bc468a70 made SRCDATE and hence PV go backwards, so we need to up PE to unbreak builds and feeds :(
10 PE = "2"
11
12 ARM_INSTRUCTION_SET = "arm"
13
14 inherit autotools
15
16 # evas-native looks at this var, so keep it
17 AUTOTOOLS_STAGE_PKGCONFIG = "1"
18
19 do_configure_prepend() {
20         touch config.rpath
21 }
22
23 do_install_prepend () {
24         for i in `find ${S}/ -name "*.pc" -type f` ; do \
25                 sed -i -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' $i
26         done
27 }
28
29 # This construction is stupid, someone with more E knowledge should change it to =+ or something
30 PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests ${PN}-static"
31
32 FILES_${PN} = "${libdir}/*.so.*"
33
34 FILES_${PN}-themes = "${datadir}/${PN}/themes \
35                       ${datadir}/${PN}/data \
36                       ${datadir}/${PN}/fonts \
37                       ${datadir}/${PN}/pointers \
38                       ${datadir}/${PN}/images \
39                       ${datadir}/${PN}/users \
40                       ${datadir}/${PN}/images \
41                       ${datadir}/${PN}/styles"
42
43 FILES_${PN}-dev   += "${bindir}/${PN}-config \
44                       ${libdir}/pkgconfig/* \
45                       ${libdir}/lib*.la \
46                       ${libdir}/*.so \
47                       ${libdir}/${PN}/*.la \
48                       ${libdir}/${PN}/*/*.la"
49
50 FILES_${PN}-static += "${libdir}/${PN}/*.a \
51                        ${libdir}/${PN}/*/*.a \
52 "
53
54 FILES_${PN}-dbg +=   "${libdir}/${PN}/.debug \
55                       ${libdir}/${PN}/*/.debug"
56
57 FILES_${PN}-tests  = "${bindir}/${PN} \
58                       ${bindir}/*_* \
59                       ${datadir}"
60