rootfs_ipk.bbclass: always specify tmp_dir in opkg-cl call with -t parameter
[openembedded.git] / classes / angstrom.bbclass
1 # anonymous support class for angstrom
2
3 # Features:
4 #
5 # * blacklist handling, set ANGSTROM_BLACKLIST_pn-blah = "message"
6 #
7
8 python () {
9     import bb
10
11     blacklist = bb.data.getVar("ANGSTROM_BLACKLIST", d, 1)
12     pkgnm = bb.data.getVar("PN", d, 1)
13
14     if blacklist:
15         bb.note("Angstrom DOES NOT support %s because %s" % (pkgnm, blacklist))
16         raise bb.parse.SkipPackage("Angstrom DOES NOT support %s because %s" % (pkgnm, blacklist))
17
18 }
19