pandora-pndstore: Fixed .desktop-file
[openpandora.oe.git] / recipes / pandora-system / pandora-pndstore.bb
index abcb186..d6ba558 100755 (executable)
@@ -6,7 +6,6 @@ PR = "r4"
 SRC_URI = " \
           git://github.com/Tempel/PNDstore.git;protocol=git;branch=master \
           file://_ctypes.so \
-          file://op_pndstore.png \   
           file://op_pndstore.desktop \
 "
 
@@ -15,30 +14,34 @@ SRCREV = "af118e0619e58716ef58"
 S = "${WORKDIR}/git"
 
 do_install() {
-          install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/
+          install -d ${D}${prefix}/pandora/scripts/pndstore/
           install -m 0775 ${S}/PNDstore ${D}${prefix}/pandora/scripts/pndstore/PNDstore
          install -m 0775 ${S}/pndst ${D}${prefix}/pandora/scripts/pndstore/pndst
          install -m 0644 ${S}/README.rst ${D}${prefix}/pandora/scripts/pndstore/README.rst
          install -m 0644 ${WORKDIR}/_ctypes.so ${D}${prefix}/pandora/scripts/pndstore/_ctypes.so
 
-         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui 
+         install -d ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui 
          install -m 0775 ${S}/pndstore_gui/PNDstore.glade ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/PNDstore.glade
          install -m 0775 ${S}/pndstore_gui/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/__init__.py
            
-         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core
+         install -d ${D}${prefix}/pandora/scripts/pndstore/pndstore_core
          install -m 0775 ${S}/pndstore_core/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/__init__.py
          install -m 0775 ${S}/pndstore_core/database_update.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/database_update.py
          install -m 0775 ${S}/pndstore_core/libpnd.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/libpnd.py
          install -m 0775 ${S}/pndstore_core/options.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/options.py
          install -m 0775 ${S}/pndstore_core/packages.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/packages.py
 
-         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg
+         install -d ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg
          install -m 0775 ${S}/pndstore_core/cfg/default.cfg ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg/default.cfg
 
          install -d ${D}${datadir}/applications/
           install -m 0644 ${WORKDIR}/op_pndstore.desktop ${D}${datadir}/applications/
 
-         install -d ${D}${prefix}/pixmaps/
-         install -m 0644 ${WORKDIR}/op_pndstore.png ${D}${datadir}/pixmaps/
+         install -d ${D}${datadir}/pixmaps/
+         install -m 0644 ${S}/resources/icon.png ${D}${datadir}/pixmaps/op_pndstore.png
 
 }
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES_${PN} += "${prefix} ${datadir}"
\ No newline at end of file