pandora-pndstore: New recipe for adding Tempels PNDStore to the OS
[openpandora.oe.git] / recipes / pandora-system / pandora-pndstore.bb
diff --git a/recipes/pandora-system/pandora-pndstore.bb b/recipes/pandora-system/pandora-pndstore.bb
new file mode 100755 (executable)
index 0000000..be865aa
--- /dev/null
@@ -0,0 +1,41 @@
+DESCRIPTION = "Support for the PND format in Pandora images (lib, daemon, init script etc.)"
+LICENSE = "lGPL"
+
+PR = "r1"
+
+SRC_URI = " \
+          git://github.com/Tempel/PNDstore.git;protocol=git;branch=master \
+          file://_ctypes.so \
+          file://op_pndstore.png \   
+          file://op_pndstore.desktop \
+"
+
+SRCREV = "af118e0619e58716ef58"
+
+do_install() {
+          install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/
+          install -m 0775 ${WORKDIR}/PNDStore ${D}${prefix}/pandora/scripts/pndstore/PNDStore
+         install -m 0775 ${WORKDIR}/pndst ${D}${prefix}/pandora/scripts/pndstore/pndst
+         install -m 0644 ${WORKDIR}/README.rst ${D}${prefix}/pandora/scripts/pndstore/README.rst
+
+         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui 
+         install -m 0775 ${WORKDIR}/pndstore_gui/PNDstore.glade ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/PNDstore.glade
+         install -m 0775 ${WORKDIR}/pndstore_gui/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/__init__.py
+           
+         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core
+         install -m 0775 ${WORKDIR}/pndstore_core/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/__init__.py
+         install -m 0775 ${WORKDIR}/pndstore_core/database_update.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/database_update.py
+         install -m 0775 ${WORKDIR}/pndstore_core/libpnd.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/libpnd.py
+         install -m 0775 ${WORKDIR}/pndstore_core/options.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/options.py
+         install -m 0775 ${WORKDIR}/pndstore_core/packages.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/packages.py
+
+         install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg
+         install -m 0775 ${WORKDIR}/pndstore_core/cfg/default.cfg ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg/default.cfg
+
+         install -d ${D}${datadir}/applications/
+          install -m 0644 ${WORKDIR}/op_pndstore.desktop ${D}${datadir}/applications/
+
+         install -d ${D}${prefix}/share/pixmaps/
+         install -m 0644 ${WORKDIR}/op_pndstore.png ${D}${datadir}/share/pixmaps/
+
+}