omap3-pandora-kernel2: update for c64-tools
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index b6def4d..754b44b 100644 (file)
@@ -4,12 +4,17 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r2"
+PR = "r13"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r2.tar.bz2"
+# git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
+# commit: 249197068c299a407a72f3c4cb88e75f3cdf3d6b
+# out-of-tree modules are built from:
+# http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
+# http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_${PR}.tar.bz2"
 
 S = "${WORKDIR}"
 
@@ -21,6 +26,10 @@ do_install() {
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
@@ -37,6 +46,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +58,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "13649475902466af040ef418c629872f"
-SRC_URI[sha256sum] = "03eed87da0e5b6b3f13c7e5e1abd92949293b20c2d8849419065c84e57efd33b"
+SRC_URI[md5sum] = "864cc331f06aa814f114cbc770ed602b"
+SRC_URI[sha256sum] = "87107cd8ccb07468ab0e0e3dd9890b74522c4f423cc3fc143d75db3e963b4c37"