omap3-pandora-kernel2: update to 3.2.61
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index 2bbb869..6cfc138 100644 (file)
@@ -4,12 +4,17 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r4"
+PR = "r18"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r4.tar.bz2"
+# git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
+# commit: 318d016e58d6c63cfb32ebb55194cd4554dfaf68
+# out-of-tree modules are built from:
+# http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
+# http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_${PR}.tar.bz2"
 
 S = "${WORKDIR}"
 
@@ -21,6 +26,10 @@ do_install() {
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
@@ -37,6 +46,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +58,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "9e64a15f07c05c0dcb6970a3bdff226e"
-SRC_URI[sha256sum] = "1d037d2e2d2c2be2a4a37b51a00623f950169b2431d5657191169b767bdbd8d8"
+SRC_URI[md5sum] = "7434654f7996c2eaec4c8daf9c5340f6"
+SRC_URI[sha256sum] = "f951d9ff87e2b3769c818767c2c9808a2086dd8f5fc5fa09f09ff484865232bd"