task-pandora-*: Commit latest Xfce and Core tasks to build PAM correctly and package...
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRI-PTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r12"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18   gimp \
19   networkmanager network-manager-applet \ 
20   synergy \
21   vnc \
22   x11vnc angstrom-x11vnc-xinit \
23   xmms \
24   xterm \
25 "
26
27 BLUETOOTH_GUI = " \
28   blueman \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 GNOME_APPS = " \
59 #  epiphany epiphany-extensions \
60 #  evince \  
61   gnome-games \
62   gnome-mplayer \
63   gcalctool \ 
64 #  gnome-bluetooth \    
65   gnome-keyring gnome-keyring-pam-plugin \
66 "
67
68 GNOME_GTK = " \
69 #  hicolor-icon-theme \
70 #  gnome-icon-theme \
71 #  angstrom-gnome-icon-theme-enable \
72 "
73
74 GSTREAMER = " \
75   gst-ffmpeg \
76   gst-omapfb \
77   gst-plugin-pulse \
78   gst-plugins-base-meta \
79 #  gst-plugins-good-meta \
80   gst-plugins-bad-meta \
81 #  gst-plugins-ugly-meta \
82 "
83
84 ICON_THEME = " \
85   tango-icon-theme \
86   tango-icon-theme-enable \
87 "
88
89 PANDORA = " \
90 #       pandora-auto-startx \
91   pandora-first-run-wizard hsetroot xtscal \
92   pandora-scripts \
93 "
94
95 PERL = " \
96   perl \
97   task-perl-module-all \
98   libnet-dbus-perl \
99   libxml-parser-perl \
100   libxml-twig-perl \
101 "
102
103 PULSEAUDIO = " \
104   pulseaudio-alsa-wrapper \
105   pulseaudio-esd-wrapper \
106   pulseaudio-module-gconf \
107   libasound-module-ctl-pulse \
108   libasound-module-pcm-pulse \
109 "
110
111 QT_SUPPORT = " \
112   qt4-x11-free \
113 #  qt4-x11-free-gles \
114 "
115
116 TOTEM = " \
117   totem \
118   totem-browser-plugin \
119   totem-plugin-bemused \
120   totem-plugin-gromit \
121   totem-plugin-media-player-keys \
122   totem-plugin-ontop \
123   totem-plugin-properties \
124   totem-plugin-screensaver \
125   totem-plugin-skipto \
126   totem-plugin-thumbnail \
127 "
128
129 TOUCHSCREEN = " \
130 #  xf86-input-evtouch \
131   xf86-input-tslib \
132   gtk-touchscreen-mode-enable \
133   libgtkstylus \
134 "
135
136 XFCE46_BASE = " \
137   xfce4-dev-tools \
138   xfwm4 \
139   xfwm4-theme-default \
140   xfce-utils \  
141   xfce4-session \     
142   xfconf \
143   xfdesktop \
144   xfce4-panel \
145   \
146   gtk-xfce-engine \
147   \
148   xfce4-panel-plugin-actions \
149   xfce4-panel-plugin-clock \
150   xfce4-panel-plugin-iconbox \
151   xfce4-panel-plugin-launcher \
152   xfce4-panel-plugin-pager \
153   xfce4-panel-plugin-separator \
154   xfce4-panel-plugin-showdesktop \
155   xfce4-panel-plugin-systray \
156   xfce4-panel-plugin-tasklist \
157   xfce4-panel-plugin-windowlist \   
158   xfce4-settings \
159   xfce-terminal \
160   thunar \
161 "
162
163 XFCE46_EXTRAS = " \
164   xfce4-notifyd \
165   xfce4-mixer \
166   xfce4-appfinder \
167   xfprint \    
168   midori \
169   orage \
170   squeeze \
171   ristretto \
172   mousepad \ 
173   gigolo \
174 "
175
176 XFCE_THEMES = " \
177   xfwm4-theme-daloa \
178   xfwm4-theme-moheli \
179   xfwm4-theme-default-4.0 \
180   xfwm4-theme-default-4.2 \
181   xfwm4-theme-default-4.4 \
182   xfwm4-theme-kokodi \
183   xfwm4-theme-moheli \
184   xfwm4-theme-sassandra \
185   xfwm4-theme-stoneage \
186   xfwm4-theme-therapy \
187   xfwm4-theme-tyrex \
188   xfwm4-theme-wallis \  
189 "
190
191 XSERVER_BASE = " \
192   ${XSERVER} \
193   dbus-x11 \
194   desktop-file-utils \
195   iso-codes \
196   mime-support \
197   notification-daemon inotify-tools \
198   xauth \
199   xdg-utils \
200   xhost \
201   xinetd \
202   xinit \
203   xlsfonts \
204   xrdb \
205   xrefresh \
206   xset \
207   xvinfo \
208 "
209
210 RDEPENDS_${PN} = " \
211   task-pandora-core \
212   angstrom-x11-base-depends \
213   ${ANGSTROM_EXTRA_INSTALL} \
214   ${APPS} \
215   ${BLUETOOTH_GUI} \
216   ${IM_CLIENT} \
217   ${DISPMAN} \
218   ${FONTS} \
219   ${GNOME_GTK} \
220   ${GNOME_APPS} \
221   ${GSTREAMER} \
222   ${ICON_THEME} \
223   ${PANDORA} \
224   ${PERL} \
225   ${PULSEAUDIO} \
226   ${QT_SUPPORT} \
227   ${TOTEM} \
228   ${TOUCHSCREEN} \
229   ${XSERVER_BASE} \
230   ${XFCE46_BASE} \
231   ${XFCE46_EXTRAS} \
232   ${XFCE_THEMES} \
233   \
234   rxvt-unicode \
235   xst \
236   suspend-desktop \
237   teleport \
238   gdk-pixbuf-loader-png \
239   gdk-pixbuf-loader-xpm \
240   gdk-pixbuf-loader-jpeg \
241   pango-module-basic-x \
242   pango-module-basic-fc \
243   xcursor-transparent-theme \   
244   mime-support \
245   xterm xmms \
246   jaaa nmap iperf gnuplot \
247   x11vnc angstrom-x11vnc-xinit \
248 "