merge of '178eac00dc5aa8338d42e8e203633bec7817bbf6'
[openembedded.git] / packages / openmoko2 / openmoko-session2.bb
index b7a159f..26eb655 100644 (file)
@@ -1,22 +1,31 @@
 DESCRIPTION = "Custom Matchbox session files for OpenMoko"
 LICENSE = "GPL"
 SECTION = "x11"
-RDEPENDS = "matchbox-common matchbox-applet-startup-monitor matchbox-panel-2"
-RDEPENDS += "openmoko-common2 openmoko-today2 openmoko-dialer2"
-RCONFLICTS = "openmoko-session"
-PR = "r35"
+RDEPENDS = "matchbox-panel-2 openmoko-common2 openmoko-today2 openmoko-dialer2 openmoko-panel-memory"
+RCONFLICTS_${PN} = "openmoko-session matchbox-common"
+PR = "r66"
 
-SRC_URI = "file://etc"
-S = ${WORKDIR}
+SRC_URI = "\
+  file://etc \
+  file://matchbox-session \
+"
+
+S = "${WORKDIR}"
+
+inherit update-alternatives
 
 do_install() {
-       install -d ${D}${sysconfdir}
-       cp -R ${S}/etc/* ${D}${sysconfdir}
-       rm -fR ${D}${sysconfdir}/.svn
-       rm -fR ${D}${sysconfdir}/matchbox/.svn
-       chmod -R 755 ${D}${sysconfdir}/
+        install -d ${D}${bindir}
+        install -m 0655 ${WORKDIR}/matchbox-session ${D}${bindir}
+        install -d ${D}${sysconfdir}
+        cp -R ${S}/etc/* ${D}${sysconfdir}
+        rm -fR ${D}${sysconfdir}/.svn
+        rm -fR ${D}${sysconfdir}/matchbox/.svn
+        chmod -R 755 ${D}${sysconfdir}/
 }
 
+PACKAGE_ARCH = "all"
+
 pkg_postinst_openmoko-session2 () {
 #!/bin/sh -e
 if [ "x$D" != "x" ]; then
@@ -26,6 +35,8 @@ fi
 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme openmoko-standard-2
 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
 # gstreamer audio settings
@@ -34,7 +45,9 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --dire
 
 }
 
-PACKAGE_ARCH = "all"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "11"
 
 CONFFILES_${PN} = "${sysconfdir}/matchbox/session"
-