binutils-2.20 is new enough for glibc_2.9, change configure script to accept it
authorMartin Jansa <martin.jansa@gmail.com>
Thu, 22 Oct 2009 03:47:41 +0000 (03:47 +0000)
committerKhem Raj <raj.khem@gmail.com>
Thu, 22 Oct 2009 23:50:16 +0000 (16:50 -0700)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch [new file with mode: 0644]
recipes/glibc/glibc_2.9.bb

diff --git a/recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch b/recipes/glibc/glibc-2.9/glibc-2.9-enable-binutils-2.2.patch
new file mode 100644 (file)
index 0000000..09200dd
--- /dev/null
@@ -0,0 +1,35 @@
+--- glibc-2.9.orig/configure.in        2009-10-22 15:38:13.000000000 +0200
++++ glibc-2.9/configure.in     2009-10-22 15:37:33.000000000 +0200
+@@ -844,10 +844,10 @@
+ # Accept binutils 2.13 or newer.
+ AC_CHECK_PROG_VER(AS, $AS, --version,
+                 [GNU assembler.* \([0-9]*\.[0-9.]*\)],
+-                [2.1[3-9]*], AS=: critic_missing="$critic_missing as")
++                [2.1[3-9]* | 2.2* ], AS=: critic_missing="$critic_missing as")
+ AC_CHECK_PROG_VER(LD, $LD, --version,
+                 [GNU ld.* \([0-9][0-9]*\.[0-9.]*\)],
+-                [2.1[3-9]*], LD=: critic_missing="$critic_missing ld")
++                [2.1[3-9]* | 2.2* ], LD=: critic_missing="$critic_missing ld")
+ # We need the physical current working directory.  We cannot use the
+ # "pwd -P" shell builtin since that's not portable.  Instead we try to
+--- glibc-2.9.orig/configure   2009-02-26 22:28:17.000000000 +0100
++++ glibc-2.9/configure        2009-10-22 15:43:11.000000000 +0200
+@@ -4531,7 +4531,7 @@
+   ac_prog_version=`$AS --version 2>&1 | sed -n 's/^.*GNU assembler.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
+   case $ac_prog_version in
+     '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+-    2.1[3-9]*)
++    2.1[3-9]* | 2.2*)
+        ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+     *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+@@ -4594,7 +4594,7 @@
+   ac_prog_version=`$LD --version 2>&1 | sed -n 's/^.*GNU ld.* \([0-9][0-9]*\.[0-9.]*\).*$/\1/p'`
+   case $ac_prog_version in
+     '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+-    2.1[3-9]*)
++    2.1[3-9]* | 2.2*)
+        ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+     *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
index 56a6ff8..cddae98 100644 (file)
@@ -65,6 +65,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
           file://tls_i486.patch;patch=1 \
           file://glibc-2.9-use-_begin.patch;patch=1 \
            file://arm-lowlevellock-include-tls.patch;patch=1 \
+           file://glibc-2.9-enable-binutils-2.2.patch;patch=1 \
            "
 
 # Build fails on sh3 and sh4 without additional patches