strace_4.5.15: Replace the use of linux/dirent{64].h
authorKhem Raj <raj.khem@gmail.com>
Tue, 24 Mar 2009 22:44:58 +0000 (15:44 -0700)
committerKhem Raj <raj.khem@gmail.com>
Tue, 24 Mar 2009 22:44:58 +0000 (15:44 -0700)
recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch [new file with mode: 0644]
recipes/strace/strace_4.5.15.bb

diff --git a/recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch b/recipes/strace/strace-4.5.15/strace-dont-include-linux-dirent-h.patch
new file mode 100644 (file)
index 0000000..1d50251
--- /dev/null
@@ -0,0 +1,23 @@
+Index: strace-4.5.14/file.c
+===================================================================
+--- strace-4.5.14.orig/file.c  2009-03-24 08:35:13.000000000 -0700
++++ strace-4.5.14/file.c       2009-03-24 08:39:43.000000000 -0700
+@@ -35,12 +35,12 @@
+ #include <dirent.h>
+ #ifdef LINUX
+-#define dirent kernel_dirent
+-#define dirent64 kernel_dirent64
+-#include <linux/types.h>
+-#include <linux/dirent.h>
+-#undef dirent
+-#undef dirent64
++struct kernel_dirent {
++      unsigned long   d_ino;
++      unsigned long   d_off;
++      unsigned short  d_reclen;
++      char            d_name[1];
++};
+ #else
+ #define kernel_dirent dirent
+ #endif
index e73fb0f..049706c 100644 (file)
@@ -1,12 +1,14 @@
 DESCRIPTION = "strace is a system call tracing tool."
 SECTION = "console/utils"
 LICENSE = "GPL"
+PR = "r1"
 
 # this recipe is missing patches for arm and sh
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_avr32 = "1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+          file://strace-dont-include-linux-dirent-h.patch;patch=1 \
           "
 
 SRC_URI_avr32 = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \