qt4: add 4.6.2
authorKoen Kooi <koen@openembedded.org>
Tue, 16 Feb 2010 09:47:02 +0000 (10:47 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 17 Feb 2010 08:43:47 +0000 (09:43 +0100)
* fix 4.6.1 references in 4.6.0 files as well
* make qt-config.patch work with QT_NO_CAST_{TO,FROM},ASCII strict checking

21 files changed:
conf/checksums.ini
recipes/qt4/files/qt-config.patch
recipes/qt4/qt-4.6.2.inc [moved from recipes/qt4/qt-4.6.1.inc with 79% similarity]
recipes/qt4/qt4-embedded-4.6.2/0006-freetype-host-includes.patch [moved from recipes/qt4/qt4-embedded-4.6.1/0006-freetype-host-includes.patch with 100% similarity]
recipes/qt4/qt4-embedded-4.6.2/0008-qt-lib-infix.patch [moved from recipes/qt4/qt4-embedded-4.6.1/0008-qt-lib-infix.patch with 100% similarity]
recipes/qt4/qt4-embedded-4.6.2/0010-no-simpledecoration-example.patch [moved from recipes/qt4/qt4-embedded-4.6.1/0010-no-simpledecoration-example.patch with 100% similarity]
recipes/qt4/qt4-embedded-4.6.2/linux.conf [moved from recipes/qt4/qt4-embedded-4.6.1/linux.conf with 100% similarity]
recipes/qt4/qt4-embedded-gles_4.6.0.bb
recipes/qt4/qt4-embedded-gles_4.6.2.bb [moved from recipes/qt4/qt4-embedded-gles_4.6.1.bb with 90% similarity]
recipes/qt4/qt4-embedded_4.6.0.bb
recipes/qt4/qt4-embedded_4.6.2.bb [moved from recipes/qt4/qt4-embedded_4.6.1.bb with 69% similarity]
recipes/qt4/qt4-tools-native_4.6.2.bb [moved from recipes/qt4/qt4-tools-native_4.6.1.bb with 53% similarity]
recipes/qt4/qt4-tools-sdk_4.6.2.bb [moved from recipes/qt4/qt4-tools-sdk_4.6.1.bb with 100% similarity]
recipes/qt4/qt4-x11-free-4.6.2/0008-qt-lib-infix.patch [moved from recipes/qt4/qt4-x11-free-4.6.1/0008-qt-lib-infix.patch with 100% similarity]
recipes/qt4/qt4-x11-free-4.6.2/0010-no-simpledecoration-example.patch [moved from recipes/qt4/qt4-x11-free-4.6.1/0010-no-simpledecoration-example.patch with 100% similarity]
recipes/qt4/qt4-x11-free-4.6.2/linux.conf [moved from recipes/qt4/qt4-x11-free-4.6.1/linux.conf with 100% similarity]
recipes/qt4/qt4-x11-free-gles_4.6.0.bb
recipes/qt4/qt4-x11-free-gles_4.6.2.bb [moved from recipes/qt4/qt4-x11-free-gles_4.6.1.bb with 92% similarity]
recipes/qt4/qt4-x11-free_4.6.0.bb
recipes/qt4/qt4-x11-free_4.6.2.bb [moved from recipes/qt4/qt4-x11-free_4.6.1.bb with 83% similarity]
recipes/qt4/qt4.inc

index 52c1274..72b015b 100644 (file)
@@ -23766,6 +23766,10 @@ sha256=55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589
 md5=0542a4be6425451ab5f668c6899cac36
 sha256=4c84b39b8a2546854ce9c0c9f761dd55da76dab2c33eeb876e3d17db1d2ea0c5
 
+[ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-4.6.2.tar.gz]
+md5=eb651ee4b157c01696aa56777fc6e0e5
+sha256=176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae
+
 [ftp://ftp.trolltech.com/qt/source/qt-x11-free-3.3.5.tar.bz2]
 md5=05d04688c0c0230ed54e89102d689ca4
 sha256=aac89e862c74b2f3ead768e50e9fa7ada1e4225fe9d1d9e05723a3279259eb96
index 3aa041a..a4a701c 100644 (file)
@@ -14,7 +14,7 @@
          qtconfig = qmake_libraryInfoFile();
 +    if (!QFile::exists(qtconfig)) {
 +        QByteArray config = getenv("QT_CONF_PATH");
-+        qtconfig = config;
++        qtconfig = QFile::decodeName(config);
 +    }
  #else
      if (!QFile::exists(qtconfig) && QCoreApplication::instance()) {
similarity index 79%
rename from recipes/qt4/qt-4.6.1.inc
rename to recipes/qt4/qt-4.6.2.inc
index 274deea..94777e5 100644 (file)
@@ -18,6 +18,10 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.
 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
 
 do_configure_prepend() {
+    for pro in $(find ${S} -name "*.pro") ; do
+        sed -i 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' $pro
+    done
+
     sed -i s:SEDME:${S}: ${WORKDIR}/linux.conf
     sed -i \
     -e /QMAKE_MOC\ /d \
@@ -27,8 +31,12 @@ do_configure_prepend() {
     ${S}/configure
 }
 
+do_configure_append() {
+    sed -e '/QMAKE_TARGET /d' -e '/TARGET /d' -i ${S}/translations/Makefile
+}
+
 QT_GLFLAGS ?= ""
-QT_CONFIG_FLAGS += "${QT_GLFLAGS}"
+QT_CONFIG_FLAGS += " -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"
 
 do_compile() {
     unset CFLAGS CXXFLAGS
index 7aadafe..915dd07 100644 (file)
@@ -4,7 +4,7 @@ PR = "${INC_PR}.1"
 PROVIDES += "qt4-embedded"
 QT_GLFLAGS = "-opengl es2 -openvg"
 
-require qt-4.6.1.inc
+require qt-4.6.0.inc
 
 
 FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
similarity index 90%
rename from recipes/qt4/qt4-embedded-gles_4.6.1.bb
rename to recipes/qt4/qt4-embedded-gles_4.6.2.bb
index 915dd07..05faa53 100644 (file)
@@ -4,7 +4,7 @@ PR = "${INC_PR}.1"
 PROVIDES += "qt4-embedded"
 QT_GLFLAGS = "-opengl es2 -openvg"
 
-require qt-4.6.0.inc
+require qt-${PV}.inc
 
 
 FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
index f2c8410..58fda71 100644 (file)
@@ -2,5 +2,5 @@ require qt4-embedded.inc
 
 PR = "${INC_PR}.0"
 
-require qt-4.6.1.inc
+require qt-4.6.0.inc
 
similarity index 69%
rename from recipes/qt4/qt4-embedded_4.6.1.bb
rename to recipes/qt4/qt4-embedded_4.6.2.bb
index f2c8410..94ecd01 100644 (file)
@@ -2,5 +2,5 @@ require qt4-embedded.inc
 
 PR = "${INC_PR}.0"
 
-require qt-4.6.1.inc
+require qt-${PV}.inc
 
similarity index 53%
rename from recipes/qt4/qt4-tools-native_4.6.1.bb
rename to recipes/qt4/qt4-tools-native_4.6.2.bb
index 48310b1..d9ab033 100644 (file)
@@ -12,4 +12,15 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.
 
 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
 
+EXTRA_OECONF = "-prefix ${prefix} \
+                -qt-libjpeg -qt-gif -system-zlib \
+                -no-libjpeg -no-libpng \
+                -no-accessibility \
+                -no-cups \
+                -no-exceptions  \
+                -no-nas-sound \
+                -no-nis \
+                -verbose -release -no-fast -static \
+                -qt3support -silent -no-rpath"
+
 TOBUILD := "src/tools/bootstrap ${TOBUILD}"
index c25f905..8d09d89 100644 (file)
@@ -3,7 +3,7 @@ PR = "${INC_PR}.3"
 
 QT_GLFLAGS = "-opengl es2 -openvg"
 
-require qt-4.6.1.inc
+require qt-4.6.0.inc
 
 QT_CONFIG_FLAGS += " \
  -no-embedded \
similarity index 92%
rename from recipes/qt4/qt4-x11-free-gles_4.6.1.bb
rename to recipes/qt4/qt4-x11-free-gles_4.6.2.bb
index 8d09d89..0f9140c 100644 (file)
@@ -3,7 +3,7 @@ PR = "${INC_PR}.3"
 
 QT_GLFLAGS = "-opengl es2 -openvg"
 
-require qt-4.6.0.inc
+require qt-${PV}.inc
 
 QT_CONFIG_FLAGS += " \
  -no-embedded \
index c2d8f66..685b7ad 100644 (file)
@@ -1,7 +1,7 @@
 require qt4-x11-free.inc
 PR = "${INC_PR}.1"
 
-require qt-4.6.1.inc
+require qt-4.6.0.inc
 
 QT_CONFIG_FLAGS += " \
  -no-embedded \
similarity index 83%
rename from recipes/qt4/qt4-x11-free_4.6.1.bb
rename to recipes/qt4/qt4-x11-free_4.6.2.bb
index 685b7ad..a8d5c3f 100644 (file)
@@ -1,7 +1,7 @@
 require qt4-x11-free.inc
 PR = "${INC_PR}.1"
 
-require qt-4.6.0.inc
+require qt-${PV}.inc
 
 QT_CONFIG_FLAGS += " \
  -no-embedded \
index 62fcec1..c98a055 100644 (file)
@@ -96,7 +96,7 @@ RRECOMMENDS_${PN} = "${LIB_PACKAGES} ${OTHER_PACKAGES}"
 RRECOMMENDS_${PN}-dev = "${DEV_PACKAGES}"
 RRECOMMENDS_${PN}-dbg = "${DBG_PACKAGES}"
 
-FILES_${QT_BASE_NAME}-tools                = "${bindir}/uic* ${bindir}/moc ${bindir}/rcc ${bindir}/qttracereplay"
+FILES_${QT_BASE_NAME}-tools                = "${bindir}/uic* ${bindir}/moc ${bindir}/rcc ${bindir}/qttracereplay ${bindir}/qdoc*"
 FILES_${QT_BASE_NAME}-assistant            = "${bindir}/*assistant* ${bindir}/qcollectiongenerator ${bindir}/qhelpconverter ${bindir}/qhelpgenerator"
 FILES_${QT_BASE_NAME}-assistant-dbg        = "${bindir}/.debug/*assistant* ${bindir}/.debug/qcollectiongenerator ${bindir}/.debug/qhelpconverter ${bindir}/.debug/qhelpgenerator"
 FILES_${QT_BASE_NAME}-common               = "${bindir}/qtconfig"
@@ -164,9 +164,9 @@ do_configure() {
             -demosdir ${bindir}/${QT_DIR_NAME}/demos \
             -platform ${TARGET_OS}-oe-g++ \
             -xplatform ${TARGET_OS}-oe-g++ \
-            -embedded ${QT_ARCH} ${QT_ENDIAN} -fast \
+            -embedded ${QT_ARCH} ${QT_ENDIAN} \
             -crossarch ${QT_ARCH} \
-            ${QT_CONFIG_FLAGS} -fast \
+            ${QT_CONFIG_FLAGS} -no-fast \
             -L${STAGING_LIBDIR} -I${STAGING_INCDIR} \
             -I${STAGING_INCDIR}/freetype2 \
             -I${STAGING_INCDIR}/mysql \