ushare: add ushare hg
authorKoen Kooi <koen@openembedded.org>
Tue, 5 Jan 2010 15:16:46 +0000 (16:16 +0100)
committerKoen Kooi <koen@openembedded.org>
Tue, 5 Jan 2010 15:21:01 +0000 (16:21 +0100)
recipes/ushare/ushare_hg.bb [new file with mode: 0644]

diff --git a/recipes/ushare/ushare_hg.bb b/recipes/ushare/ushare_hg.bb
new file mode 100644 (file)
index 0000000..0e24cfb
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "ushare is a UPnP media server"
+LICENSE = "GPL"
+HOMEPAGE = "http://ushare.geexbox.org/"
+DEPENDS = "gamin libdlna libupnp virtual/libiconv virtual/libintl"
+
+PV = "1.1a"
+PR = "r1"
+PR_append = "+hg${SRCPV}"
+SRCREV = "2e40e513a4a0"
+
+SRC_URI = "hg://hg.geexbox.org;proto=http;module=ushare;rev=${SRCREV} \
+"
+
+S= "${WORKDIR}/ushare"
+
+inherit autotools gettext
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure () {
+       ${S}/configure \
+                   --prefix=${prefix} \
+                   --bindir=${bindir} \
+                   --localedir=${datadir}/locale \
+                   --sysconfdir=${sysconfdir} \
+                   --disable-strip \
+            --enable-fam \
+            --cross-compile
+}
+