zip: fix QA errors
authorKoen Kooi <koen@openembedded.org>
Mon, 22 Jun 2009 12:33:39 +0000 (14:33 +0200)
committerKoen Kooi <koen@openembedded.org>
Mon, 22 Jun 2009 12:33:39 +0000 (14:33 +0200)
recipes/zip/zip.inc
recipes/zip/zip_2.32.bb

index 8d04bd5..b115425 100644 (file)
@@ -4,8 +4,8 @@ LICENSE = "Info-ZIP"
 
 SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tar.gz"
 
-EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
-               'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC} ${LDFLAGS}' 'AS=${CC} -c' 'CPP=${CPP}' \
+               'CFLAGS=-I. -DUNIX ${CFLAGS} ${LDFLAGS}' 'LFLAGS1=${LDFLAGS}' 'INSTALL=install' \
                'BINFLAGS=0755' 'INSTALL_D=install -d'"
 
 do_compile() {
index 0c57235..54d52e0 100644 (file)
@@ -1,3 +1,3 @@
 require zip.inc
 
-PR ="r1"
+PR ="r2"