xfce4-panel: Add 4.6.3 and support new style checksums in xfce46.bbclass.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Thu, 22 Apr 2010 11:10:17 +0000 (12:10 +0100)
committerDavid-John Willis <John.Willis@Distant-earth.com>
Thu, 22 Apr 2010 11:10:17 +0000 (12:10 +0100)
classes/xfce46.bbclass
recipes/xfce-base/xfce4-panel_4.6.3.bb [new file with mode: 0644]

index c24dfa4..7e3e418 100644 (file)
@@ -11,7 +11,7 @@ SECTION ?= "x11/xfce"
 
 XFCE_VERSION = ${PV}
 
-SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2"
+SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2;name=archive"
 
 inherit autotools gtk-icon-cache pkgconfig
 
diff --git a/recipes/xfce-base/xfce4-panel_4.6.3.bb b/recipes/xfce-base/xfce4-panel_4.6.3.bb
new file mode 100644 (file)
index 0000000..0dfa94b
--- /dev/null
@@ -0,0 +1,34 @@
+# xfce4-panel OE build file
+
+DESCRIPTION = "Xfce4 Panel"
+DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce46
+
+SRC_URI[archive.md5sum] = "0b715abb929220f136483ccd7303ff62"
+SRC_URI[archive.sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_stage() {
+    autotools_stage_all
+}
+
+do_install() {
+    oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+       plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+       plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+       do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+                         '${PN} plugin for %s', extra_depends='', prepend=True,
+                         aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+                                            '${sysconfdir}/xdg/xfce/panel/%s-*',
+                                            '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+                                            '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"