xf86-input-tslib: Add patch to stop events being flooded upto to the X server.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Mon, 7 Dec 2009 09:50:05 +0000 (09:50 +0000)
committerPhilip Balister <philip@balister.org>
Mon, 14 Dec 2009 23:28:09 +0000 (18:28 -0500)
recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch [new file with mode: 0644]
recipes/xorg-driver/xf86-input-tslib_0.0.6.bb

diff --git a/recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch b/recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch
new file mode 100644 (file)
index 0000000..e989717
--- /dev/null
@@ -0,0 +1,22 @@
+Index: xf86-input-tslib-0.0.6/src/tslib.c
+===================================================================
+--- xf86-input-tslib-0.0.6.orig/src/tslib.c    2009-11-29 20:03:29.734794324 +0000
++++ xf86-input-tslib-0.0.6/src/tslib.c 2009-11-29 20:29:24.066794215 +0000
+@@ -205,7 +205,7 @@
+                */
+               switch (priv->state) {
+                        case BUTTON_EMULATION_OFF :
+-                               if(priv->lastp != samp.pressure) {
++                               if(!!priv->lastp != !!samp.pressure) {
+                                        priv->lastp = samp.pressure;
+                                        xf86PostButtonEvent(local->dev, TRUE,
+                                                1, !!samp.pressure, 0, 2,
+@@ -512,7 +512,7 @@
+       s = xf86CheckStrOption(dev->commonOptions, "path", NULL);
+       if (!s)
+               s = xf86CheckStrOption(dev->commonOptions, "Device", NULL);
+- 
++
+       priv->ts = ts_open(s, 1);
+       xfree(s);
index 785e5f4..e86f0c7 100644 (file)
@@ -4,7 +4,10 @@ DESCRIPTION = "X.Org X server -- tslib input driver"
 RRECOMMENDS += "hal tslib-calibrate"
 DEPENDS += "tslib"
 
+PR = "r2"
+
 SRC_URI = "http://www.pengutronix.de/software/xf86-input-tslib/download/xf86-input-tslib-${PV}.tar.bz2 \
+           file://dontfloodevents006.patch;patch=1 \
            file://10-x11-input-tslib.fdi"
 
 do_configure_prepend() {
@@ -17,4 +20,3 @@ do_install_append() {
 }
 
 FILES_${PN} += "${datadir}/hal"
-