pixman git: add patches to fix NEON bugs
authorKoen Kooi <koen@openembedded.org>
Thu, 4 Jun 2009 14:54:02 +0000 (16:54 +0200)
committerKoen Kooi <koen@Powerbook-3.local>
Fri, 5 Jun 2009 15:48:11 +0000 (17:48 +0200)
recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch [new file with mode: 0644]
recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch [new file with mode: 0644]
recipes/xorg-lib/pixman_git.bb

diff --git a/recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch b/recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch
new file mode 100644 (file)
index 0000000..02bd13a
--- /dev/null
@@ -0,0 +1,25 @@
+From 82ea3295e435b49478cf7943100b22286baf47dc Mon Sep 17 00:00:00 2001
+From: Jonathan Morton <jmorton@sd070.hel.movial.fi>
+Date: Thu, 4 Jun 2009 10:43:41 +0300
+Subject: [PATCH] Fix filler bug.
+
+---
+ pixman/pixman-arm-neon.c |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/pixman/pixman-arm-neon.c b/pixman/pixman-arm-neon.c
+index 18e9a16..67f0b63 100644
+--- a/pixman/pixman-arm-neon.c
++++ b/pixman/pixman-arm-neon.c
+@@ -1377,7 +1377,7 @@ pixman_fill_neon (uint32_t *bits,
+       "beq            2f\n"
+       "strh           %[color], [r4]!\n"
+       "2:\n"
+-      "tst            r5, #1\n"
++      "tst            %[width], #1\n"
+       "beq            2f\n"
+       "strb           %[color], [r4]!\n"
+       "2:\n"
+-- 
+1.5.6.3
+
diff --git a/recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch b/recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch
new file mode 100644 (file)
index 0000000..e23b9cd
--- /dev/null
@@ -0,0 +1,35 @@
+From 5cdd43ac753780ef2cfd6adde822af5dcba6091f Mon Sep 17 00:00:00 2001
+From: Jonathan Morton <jmorton@sd070.hel.movial.fi>
+Date: Thu, 4 Jun 2009 15:11:40 +0300
+Subject: [PATCH] Really fix filler bug.
+
+---
+ pixman/pixman-arm-neon.c |    6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/pixman/pixman-arm-neon.c b/pixman/pixman-arm-neon.c
+index cfb69f4..0c05f64 100644
+--- a/pixman/pixman-arm-neon.c
++++ b/pixman/pixman-arm-neon.c
+@@ -1369,15 +1369,15 @@ pixman_fill_neon (uint32_t *bits,
+       "2:\n"
+       "tst            %[width], #4\n"
+       "beq            2f\n"
+-      "str            %[color], [r4]!\n"
++      "str            %[color], [r4], #4\n"
+       "2:\n"
+       "tst            %[width], #2\n"
+       "beq            2f\n"
+-      "strh           %[color], [r4]!\n"
++      "strh           %[color], [r4], #2\n"
+       "2:\n"
+       "tst            %[width], #1\n"
+       "beq            2f\n"
+-      "strb           %[color], [r4]!\n"
++      "strb           %[color], [r4], #1\n"
+       "2:\n"
+       "subs           %[height], %[height], #1\n"
+-- 
+1.5.6.3
+
index 128a3f3..6c05c0c 100644 (file)
@@ -4,13 +4,17 @@ DESCRIPTION = "Low-level pixel manipulation library."
 LICENSE = "X11"
 
 PV = "0.15.8"
+PR = "r1"
 PR_append = "+gitr${SRCREV}"
 
-SRCREV = "a673a898e1e119836c9c68eff71feaec49f97bf1"
+SRCREV = "3c570a815afb282df01f41acad385ff0e3e33899"
 
 DEFAULT_PREFERENCE = "-1"
 
-SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git \
+file://0041-Fix-filler-bug.patch;patch=1 \
+file://0042-Really-fix-filler-bug.patch;patch=1 \
+"
 
 S = "${WORKDIR}/git"