ti-codec-combos: Use DVSDK Codec Combos to be aligned with DVSDK
authorRoger Monk <r-monk@ti.com>
Mon, 30 Mar 2009 18:01:53 +0000 (19:01 +0100)
committerKoen Kooi <koen@openembedded.org>
Mon, 30 Mar 2009 18:11:38 +0000 (20:11 +0200)
recipes/dsplink/ti-codec-combos_3.16.bb
recipes/dsplink/ti-codec-engine_2.23.bb

index dc1ef9f..dd97a57 100644 (file)
@@ -4,7 +4,9 @@ LICENCE = "unknown"
 
 require ti-paths.inc
 
-SRC_URI = "http://software-dl.ti.com/sdo/sdo_apps_public_sw/omap3530_dvsdk_combos_tspa/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin \
+
+# Tar-Up Codec Combos from the OMAP DVSDK (http://www.ti.com/dvevmupdates) and drop in files/
+SRC_URI = "file://omap3530_dvsdk_combos_3_16.tar.gz \
     "
 
 S = "${WORKDIR}/omap3530_dvsdk_combos_3_16"
@@ -20,21 +22,6 @@ export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/pa
 # Needed for now since makefile in latest package assumes this is set
 export CODEC_INSTALL_DIR="${S}"
 
-# Helper function to run the binary installer and unpack the tar.gz in the same place as it was before - this could be optimised later
-do_accept_license() {
-        export HOME="${WORKDIR}"
-       chmod +x ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin
-        ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin --mode silent --prefix ${S}_install
-        cd "${S}_install"
-       tar -xzvf omap3530_dvsdk_combos_tspa_3_16.tar.gz
-       if [ -d ${S} ] ; then 
-            rm -rf ${S}
-        fi
-        mv omap3530_dvsdk_combos_tspa_3_16 ${S}
-}
-
-addtask accept_license after do_unpack before do_configure
-
 do_compile() {
 
         # For now, remove the reference to Rules.make and swap prod for eval, since this only has eval libs included
index 78684f4..a42c33b 100644 (file)
@@ -125,7 +125,7 @@ do_compile () {
       COMPILER="${KERNEL_CC}" \
       ARCHIVER="${KERNEL_AR}" \
       KERNEL_DIR="${STAGING_KERNEL_DIR}" \
-      clean default
+      clean all
 
     # Build the gpp samples
     cd ${DSPLINK}/gpp/src/samples
@@ -230,7 +230,8 @@ do_compile () {
           CGTOOLS_V5T="${CROSS_DIR}" \
           CGTOOLS_C64P="${TICGTOOLSDIR}" \ 
           -C ${S}/examples/ti/sdo/ce/examples/$i \
-         clean all
+         clean 
+#all
     done    
 }