iptables: Add patch to use cross ar and ranlib.
authorJeremy Puhlman <jpuhlman@mvista.com>
Wed, 15 Jul 2009 02:10:03 +0000 (19:10 -0700)
committerChris Larson <clarson@mvista.com>
Thu, 27 Aug 2009 20:21:16 +0000 (13:21 -0700)
Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com>
Signed-off-by: Chris Larson <clarson@mvista.com>
recipes/iptables/files/cross-iptables.diff [new file with mode: 0644]
recipes/iptables/iptables_1.3.8.bb

diff --git a/recipes/iptables/files/cross-iptables.diff b/recipes/iptables/files/cross-iptables.diff
new file mode 100644 (file)
index 0000000..8027b07
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/extensions/Makefile~     2007-03-21 17:04:36.000000000 -0700
++++ b/extensions/Makefile      2009-07-14 19:01:56.000000000 -0700
+@@ -80,10 +80,10 @@
+ ifdef NO_SHARED_LIBS
+ extensions/libext.a: $(EXT_OBJS)
+-      rm -f $@; ar crv $@ $(EXT_OBJS)
++      rm -f $@; $(AR) crv $@ $(EXT_OBJS); $(RANLIB) $@
+ extensions/libext6.a: $(EXT6_OBJS)
+-      rm -f $@; ar crv $@ $(EXT6_OBJS)
++      rm -f $@; $(AR) crv $@ $(EXT6_OBJS); $(RANLIB) $@
+ extensions/initext.o: extensions/initext.c
+ extensions/initext6.o: extensions/initext6.c
index 040be06..520e336 100644 (file)
@@ -1,8 +1,9 @@
 require iptables.inc
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "\
   file://getsockopt-failed.patch;patch=1 \
   file://iptables-use-s6_addr32.patch;patch=1 \
+  file://cross-iptables.diff;patch=1 \
 "