syslinux-native: leave only 3.63 version
authorOtavio Salvador <otavio@ossystems.com.br>
Thu, 15 Jan 2009 18:31:18 +0000 (16:31 -0200)
committerOtavio Salvador <otavio@ossystems.com.br>
Thu, 22 Jan 2009 20:50:55 +0000 (18:50 -0200)
The only user (or a possible one) of it was OpenMoko but they were
preferring the version 3.36 that is not available; so looks safe to
bump it to 3.63 since it was't notice by them.

The versions that has been droped are 2.11, 3.11 and 3.31.

conf/distro/include/preferred-om-2008-versions.inc
packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch [deleted file]
packages/syslinux/syslinux-native_2.11.bb [deleted file]
packages/syslinux/syslinux-native_3.11.bb [deleted file]
packages/syslinux/syslinux-native_3.31.bb [deleted file]
packages/syslinux/syslinux-native_3.63.bb
packages/syslinux/syslinux.inc [deleted file]
packages/syslinux/syslinux3.inc [deleted file]

index b3bcb26..4bba014 100644 (file)
@@ -1798,7 +1798,7 @@ PREFERRED_VERSION_syncml-client ?= "0.1"
 PREFERRED_VERSION_synergy ?= "1.3.1"
 PREFERRED_VERSION_sysfsutils ?= "2.0.0"
 PREFERRED_VERSION_sysklogd ?= "1.4.1"
-PREFERRED_VERSION_syslinux-native ?= "3.36"
+PREFERRED_VERSION_syslinux-native ?= "3.63"
 PREFERRED_VERSION_syslog-ng ?= "1.6.11"
 PREFERRED_VERSION_sysvinit ?= "2.86"
 PREFERRED_VERSION_t1lib ?= "5.0.2"
diff --git a/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch b/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch
deleted file mode 100644 (file)
index 7243464..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- syslinux-2.11/ldlinux.asm.orig     2005-11-01 14:25:10.767581544 -0700
-+++ syslinux-2.11/ldlinux.asm  2005-11-01 14:25:42.175806768 -0700
-@@ -724,7 +724,6 @@
-               
-               mov eax,[bsHidden]              ; Hidden sectors
-               add edx,[bxResSectors]
--              add eax,edx
-               mov ecx,[bxFATsecs]             ; Sectors/FAT
- fat_load_loop:        
-               mov ebp,ecx                     ; Make sure high EBP = 0
diff --git a/packages/syslinux/syslinux-native_2.11.bb b/packages/syslinux/syslinux-native_2.11.bb
deleted file mode 100644 (file)
index 6fe5491..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-PR ="r1"
-
-SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2 \
-         file://edx_assume_zero.patch;patch=1"
-
-require syslinux.inc
-
-do_compile() {
-       oe_runmake syslinux
-}
diff --git a/packages/syslinux/syslinux-native_3.11.bb b/packages/syslinux/syslinux-native_3.11.bb
deleted file mode 100644 (file)
index 4eb8c4f..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-PR ="r1"
-
-SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2 "
-
-require syslinux3.inc
diff --git a/packages/syslinux/syslinux-native_3.31.bb b/packages/syslinux/syslinux-native_3.31.bb
deleted file mode 100644 (file)
index 6971874..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
-
-require syslinux3.inc
index d9019a4..471ef1b 100644 (file)
@@ -1,3 +1,38 @@
+# syslinux-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A multi-purpose linux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+LICENSE="GPL"
+PR="r1"
+
+# If you really want to run syslinux, you need mtools.  We just want the
+# ldlinux.* stuff for now, so skip mtools-native
+DEPENDS="nasm-native"
+
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
 
-require syslinux3.inc
+S="${WORKDIR}/syslinux-${PV}"
+
+inherit native
+
+STAGE_TEMP="${WORKDIR}/stage_temp"
+
+do_stage() {
+       install -d ${STAGE_TEMP}
+       oe_runmake install INSTALLROOT="${STAGE_TEMP}"
+
+       install -d ${STAGING_BINDIR}
+       install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
+       install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
+
+       # When building media, the syslinux binary isn't nearly as useful
+       # as the DOS data files, so we copy those into a special location
+       # for usage during a image build stage
+
+       install -d ${STAGING_DATADIR}/syslinux
+       install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
+       install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
+       install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
+}
diff --git a/packages/syslinux/syslinux.inc b/packages/syslinux/syslinux.inc
deleted file mode 100644 (file)
index 41be168..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# syslinux-native OE build file
-# Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION="A multi-purpose linux bootloader"
-HOMEPAGE="http://syslinux.zytor.com/"
-LICENSE="GPL"
-
-# If you really want to run syslinux, you need mtools.  We just want the
-# ldlinux.* stuff for now, so skip mtools-native
-DEPENDS="nasm-native"
-
-S="${WORKDIR}/syslinux-${PV}"
-
-
-inherit native
-
-do_stage() {
-       install -d ${STAGING_BINDIR}
-       install -m 755 ${S}/syslinux ${STAGING_BINDIR}
-
-       # When building media, the syslinux binary isn't nearly as useful
-       # as the DOS data files, so we copy those into a special location
-       # for usage during a image build stage
-
-       install -d ${STAGING_DATADIR}/syslinux
-       install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
-       install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
-}
diff --git a/packages/syslinux/syslinux3.inc b/packages/syslinux/syslinux3.inc
deleted file mode 100644 (file)
index 95124d6..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-require syslinux.inc
-
-STAGE_TEMP="${WORKDIR}/stage_temp"
-
-do_stage() {
-       install -d ${STAGE_TEMP}
-       oe_runmake install INSTALLROOT="${STAGE_TEMP}"
-
-       install -d ${STAGING_BINDIR}
-       install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
-       install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
-
-       # When building media, the syslinux binary isn't nearly as useful
-       # as the DOS data files, so we copy those into a special location
-       # for usage during a image build stage
-
-       install -d ${STAGING_DATADIR}/syslinux
-       install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
-       install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
-       install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
-}