geos_3.2.0.bb: Refine PACKAGES and contents.
authorKhem Raj <raj.khem@gmail.com>
Tue, 23 Mar 2010 22:17:48 +0000 (15:17 -0700)
committerKhem Raj <raj.khem@gmail.com>
Tue, 23 Mar 2010 22:20:40 +0000 (15:20 -0700)
* Create geos-c1 for C libraries
* Forcibly package libgeos into geos package
* Enhance description.
* Add --disable-inline, its not needed if gcc 4.4 or newer
  is in use. but many distros still use older gcc 4.x

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/geos/geos_3.2.0.bb

index 832452f..388d059 100644 (file)
@@ -1,20 +1,30 @@
-DESCRIPTION = "GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS)."
+DESCRIPTION = "GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS). GEOS provides a spatial object model and fundamental geometric functions. It implements the geometry model defined in the OpenGIS Consortium Simple Features Specification for SQL"
 HOMEPAGE = "http://geos.refractions.net/"
 LICENSE = "LGPL"
 
 DEPENDS = "boost"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2;name=geos \
           file://geos-arm.patch;patch=1 \
          "
 
-S = "${WORKDIR}/geos-${PV}"
+S = "${WORKDIR}/${PN}-${PV}"
 
 inherit autotools pkgconfig lib_package binconfig
 
-EXTRA_OECONF = "--disable-swig"
+PACKAGES += "${PN}-c1"
+
+DESCRIPTION_${PN}-c1 = "Geometry engine for Geographic Information Systems - C Library"
+FILES_${PN}-c1 := "${libdir}/libgeos_c.so.*"
+
+DESCRIPTION_${PN} = "Geometry engine for Geographic Information Systems - C++ Library"
+FILES_${PN} := "${libdir}/libgeos-*"
+
+# --disable-inline is not needed if gcc 4.4+ is used
+EXTRA_OECONF = "--disable-swig --disable-inline"
+
 SRC_URI[geos.md5sum] = "bfad7129680f0107b6ca9a2b92a2c440"
 SRC_URI[geos.sha256sum] = "0a43b76429fd94fd572d79869f3ca5acdf44a9fa73844aa655016f09aaa1e6c7"