wvstreams_4.4.1.bb: Make it compilable with gcc 4.3
authorKirtika Ruchandani <kirtibr@gmail.com>
Sat, 8 Aug 2009 03:32:18 +0000 (20:32 -0700)
committerKhem Raj <raj.khem@gmail.com>
Sat, 8 Aug 2009 03:32:18 +0000 (20:32 -0700)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/wvstreams/files/dont-forget-header.patch [new file with mode: 0644]
recipes/wvstreams/files/gcc4.3.patch [new file with mode: 0644]
recipes/wvstreams/wvstreams_4.4.1.bb

diff --git a/recipes/wvstreams/files/dont-forget-header.patch b/recipes/wvstreams/files/dont-forget-header.patch
new file mode 100644 (file)
index 0000000..9befe49
--- /dev/null
@@ -0,0 +1,13 @@
+Index: wvstreams-4.4.1/include/uniconfkey.h
+===================================================================
+--- wvstreams-4.4.1.orig/include/uniconfkey.h  2009-07-28 17:42:39.000000000 +0530
++++ wvstreams-4.4.1/include/uniconfkey.h       2009-07-28 17:42:55.000000000 +0530
+@@ -9,7 +9,7 @@
+ #include "wvstring.h"
+ #include "wvlinklist.h"
+-
++#include <limits.h>
+ // The Python headers try to #define ANY as void.  If we're building Python
+ // wrappers, get rid of that.
diff --git a/recipes/wvstreams/files/gcc4.3.patch b/recipes/wvstreams/files/gcc4.3.patch
new file mode 100644 (file)
index 0000000..f7315ee
--- /dev/null
@@ -0,0 +1,15 @@
+Index: wvstreams-4.4.1/include/wvserialize.h
+===================================================================
+--- wvstreams-4.4.1.orig/include/wvserialize.h 2009-07-28 17:46:50.000000000 +0530
++++ wvstreams-4.4.1/include/wvserialize.h      2009-07-28 17:48:30.000000000 +0530
+@@ -348,8 +348,9 @@
+  * (zero) character.  Serialized WvStrings are guaranteed not to contain nul
+  * except as the last character.
+  */
++/*No storage class allowed here as per gcc 4.3 specs*/
+ template <>
+-extern WvString _wv_deserialize<WvString>(WvBuf &buf);
++WvString _wv_deserialize<WvString>(WvBuf &buf);
+ /** Deserialize a WvBuf. */
index 8cf1d1b..6aeefc7 100644 (file)
@@ -1,12 +1,17 @@
 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
 LICENSE = "LGPL"
 DESCRIPTION = "WvStreams is a network programming library in C++"
-DEPENDS = "zlib openssl (>= 0.9.8)"
+#DEPENDS = "zlib openssl (>= 0.9.8)"
+DEPENDS = "zlib openssl"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
-           file://build-fixes-and-sanity.patch;patch=1 "
+       file://build-fixes-and-sanity.patch;patch=1 \
+       file://dont-forget-header.patch;patch=1 \
+       file://gcc4.3.patch;patch=1 \
+       "
+
 
 inherit autotools pkgconfig